Custom file locations

I’m trying to set up Syncthing on my Windows 11 machines, one desktop, and one laptop using SyncTrazor windows GUI. It works fine, I’ve got a couple of folders in My Documents shared from my desktop but when they sync to the laptop, they go into the user directory (C:\Users\USERID\Sync<FolderName>).

This is not reasonable. You keep documents in your document folder, not under the User ID. I WANT to have them synced to the same folder structure as the desktop. It makes things easier to find.

I’ve tried changing the path in the advanced settings. This ended badly. The sync simply STOPPED until I reverted it back.

I’ve searched and seen a few suggestions about changing the config.xml file. However, there is nothing obvious here, at least for someone unfamiliar with this kind of file. It has no comments to help.

How do I change the location? I only want to sync a few folders of documents I use regularly on both computers. There has to be a way to do this.

Eric the Grey

Always make sure you have a back-up of your data before ofc,

It’s covered in the FAQ ( FAQ — Syncthing documentation)

How I did it:

  • stop Syncthing (crucial)
  • move the entire folder including all its content to the desired location (including the .stfolder folder inside it)
  • manually edit the config.xml file and change the folder’s path to the new location - it should be correctly formatted though
  • start Syncthing back up

But the easier way is described in the linked docs:) (practically; remove the folder from the GUI, move the folder to the desired location, and then add the folder again)

As for the easier way, the dialog asks for the path when the folder is added. That is the best time to set it to what you want it to be.

1 Like

Trouble is, the config.xml file does not have the folders listed in it. Nothing to indicate where I should edit. Also, no indication of how it should be “correctly formatted”. I would assume, the full path (i.e.: C:\Users\USERID\Documents\Vault) but that path would not work under the advanced settings.

I tried that initially, and the browse option was unclickable. The app would not let me change the location to place the folder.

However, I just redid all three folders in question (deleted and re-synced) and it worked. I’m not sure what happened in between, but it worked.

Thank you both for your assistance.

Eric the Grey

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.