Current WiFi SSID is not whitelisted - but it is

Hello, I’m trying to set up Syncthing for the first time. I have an Android phone and a Windows 10 PC running Synctrayzor.

So far, I have got a setup where it is syncing my Camera directory on my phone to my Pictures folder on my PC.

This works great until I try to tighten the security on the phone. I am connected on my phone to my home wifi (let’s call it ‘HomeWifi’) and whitelisted that SSID from the list in the app’s settings menu. The app will then not let me past a popup that says my WiFi’s SSID has not been whitelisted. Going into the settings, I can confirm that HomeWifi has been checked off. If I uncheck HomeWifi (so that no SSIDs are selected) then sync resumes.

I have confirmed that my phone is connected to HomeWifi from the Android wifi menu, and that Syncthing has Locations permissions enabled.

Have I done something wrong in my setup? Is this a known issue? Please let me know if there is any further information I could provide on this issue.

I think there is quite a few questions like this on the forum.

You need to give syncthing location permissions for it to be able to read wifi ssids.

1 Like

Hi,

I have given Syncthing locations permissions, as I have said in my original post. There is still no detection of my SSID.

Is location also enabled? (not the app permission, the global location toggle thingy).

2 Likes

Ah ha - it’s not, I keep my GPS off. Thanks for your help!