Creating folder in /root in WD NAS

Hello, Noobie here. Syncthing is trying to create my folder in the root directory of the NAS instead of one of the hard drives. I have it running OK on two windows 10 computers, or it appears to be. I think it may be a matter of the path, but I’m out of guesses. I’ve removed the folder and put it back following the prompts many times. I first ran out of room with inotify, but edited the max_user_watches to 204800, then it gave me an “insufficient space in basic” error on practically every file. I can see why if it’s creating them in the root directory. I’m trying to sync about 12 Gb. Can anyone tell me how to fix it?

If you don’t want it to sync stuff at the root drive, why did you leave the path pointing at it?

You should change the path to point wherever you want.

I just enjoy being humiliated on a public forum. But thanks for the help anyway.

I finally figured it out, and the rest of this post will be for anyone who has had the same challenges as I getting Syncthing to run on a MyCloudEX2Ultra with limited linux skills.

I couldn’t find anywhere how to access the hard drives of the MyCloudEX2Ultra, but finally figured out the directory structure. I had to go through /shares/public/* to access it. I tried several combinations previously to no avail. It would create the shared folder(s) in the root directory and fill up the system RAM, and give me the error “insufficient space in basic .” and couldn’t sync anything else.

I first installed Snycthing on my windows 10 PC and Laptop, and tried to install SyncTrayzor, but it couldn’t load Syncthing because it was already running a newer version. In hindsite, I could have probably copied the Syncthing executable to the SyncTrayzor folder and ran it (after I killed Syncthing), but it is working OK with just the browsere GUI, so I uninstalled SyncTrayzor. Finally got the two PC’s synced after a few bumps.

Next I downloaded the tiny binary for the NAS, and installed it manually. It installed an older version, Syncthing 1.3, but updated it during the night to 1.9. First error was the aforementioned “insufficient space in basic” which took me until this morning to fix, after I finally figured out how to SSH into the NAS. I had to log in as user sshd, and I only found the user name after a pretty exhaustive search on the internet. I had enabled SSH on the NAS, and created a password, but it wouldn’t let me in until I logged in as user sshd with my newly created password. After I got in, I figured out the directory structure and got rid of my previous garbage.

OK, it is finally syncing more than a few Mb, and I get the error “failed to setup inotify handler. Please increase inotify limits, see”, which I had got before but couldn’t run the fix because I couldn’t get in the NAS. I run the fix found on the Syncthing website, reboot, and now the only error I get is “Syncthing should not run as a privileged or system user. Please consider using a normal user account.” I haven’t found the answer to that yet, but I think I can live with that one. It may have been because I installed it as administrator, I don’t know. Everything is in sync, quiet, and smooth now, and I am thankful. I appreciate all the folks that worked hard to put this together and keep it going, most of which are probably uncompensated, and I thank them from the bottom of my heart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.