Crash loop because of files >500MB

(Gabriel) #1

Hello,

I am pretty new to syncthing. I set it up and it worked perfectly. But now the point is reached where some devices try to sync files that have a size about 500mb’s.

Syncthing tries to sync it and crashes every single time.

More information: It is set up on a pi. 2 android devices are connected (there are the large files) and 1 Win PC.

Hope you can help me. greetz. Gabriel

(Simon) #2

Please show us logs from a crash.

(Gabriel) #3

Where can I find the log?

BTW way my version says: v0.14.18-dfsg1, Linux apt upgrade says i already have the newest version but git says the newest is 1.1.3.

this is how Installed it:

curl -s https://syncthing.net/release-key.txt | apt-key add -
echo "deb http://apt.syncthing.net/ syncthing release" | tee -a /etc/apt/sources.list.d/syncthing-release.list
apt-get update
apt-get install syncthing
Reading package lists... Done
Building dependency tree
Reading state information... Done
syncthing is already the newest version (0.14.18+dfsg1-2+b1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

https://znil.net/index.php?title=Raspberry_Pi_Syncthing_installieren

Should get the right version, am I missing something?

(Simon) #4

Something didn’t work when adding the syncthing.net repository, the version you installed is the debian stable one which is ancient. Check that the content of /etc/apt/sources.list.d/syncthing-release.list is as expected. Also apt-cache policy syncthing might give a hint.

(Gabriel) #5

Thats the output of apt-cache policy syncthing:

syncthing:
  Installed: 0.14.18+dfsg1-2+b1
  Candidate: 0.14.18+dfsg1-2+b1
  Version table:
     1.1.3 500
        500 apt.syncthing .net syncthing/stable armhf Packages
     1.1.2 500
        500 apt.syncthing .net syncthing/stable armhf Packages
     1.1.1 500
        500 apt.syncthing .net syncthing/stable armhf Packages
     0.14.37+ds1-1~bpo9+1 100
        100 httpredir.debian .org /debian stretch-backports/main armhf Packages
 *** 0.14.18+dfsg1-2+b1 900
        900 httpredir.debian .org /debian stretch/main armhf Packages
        100 /var/lib/dpkg/status

https://pastebin.com/xkMCfkwg (original) (had to add a space to links because new users are limtited to post only 2 links)

source list: deb https://apt.syncthing.net/ syncthing stable

(Catfriend1) #6

I would be careful syncing files that are too large with Android. Had it sometimes that this consumed too much RAM during sync spike activity leading to never ending retry attempts and/or random phone reboots. If you have a high end phone syncing up to 2 gbyte files should work, old phones like samsung s2, s3 may have 200 mbyte file max, moto x around 750 mbyte max. That’s just what I remember from trying.

(Gabriel) #7

Thanks for your hint. I think it should work I am using a BB KeyOne

(Simon) #8

The preferences aren’t right, aka those instructions are lacking (and probably also our instructions, maybe a default changed). You also need to set priority of apt.syncthing.net to 900. Write

Package: *syncthing*
Pin: origin apt.syncthing.net
Pin-Priority: 900

to /etc/apt/preferences.d/syncthing.

Also I did sync files of ~2GB to android without issues, it’s definitely possible.

1 Like
(Gabriel) #9

Perfect, that worked. Thank you very much!