Could not add port mapping

New user, setting up a sync between Macbook and ubuntu headless server.

using apt-get to install, then run syncthing, I get a lot of ‘Could not add port mapping’. I am not able to see the gui from the MacBook.

for ubuntu I followed: I changed firewall rules: /t/ubuntu-server-ufw-configuration-help/21897/6

I followed /t/syncthing-server-disconects-when-the-ssh-session-is-closed/11168 to check service chris@nas04:~$ systemctl --user status syncthing.service ○ syncthing.service - Syncthing - Open Source Continuous File Synchronization Loaded: loaded (/usr/lib/systemd/user/syncthing.service; disabled; vendor preset: enabled) Active: inactive (dead) Docs: man:syncthing(1) chris@nas04:~$

I tried changing the config file as in docs /users/faq.html#how-do-i-access-the-web-gui-from-another-computer but there is no .config/syncthing/config.xml file. as you might find in dig ocean dot com /community/tutorials/how-to-install-and-configure-syncthing-to-synchronize-directories-on-ubuntu-14-04

But all of that is irrelevant because this forum st /t/couldnt-add-port-mapping-for-192-168-178-xx-error-conflictinmappingentry-718/21605 tells me if my fritzbox 7530 thinks it is uptodate on version 7.57, then I cannot get version 7.8, where the issue is resolved.

Not sure where I am going or what is happening. Would someone take a moment to direct me?

The port mapping error is a UPnP issue with your router and isn’t related to remote access to Syncthing’s web UI.

According to the systemctl output, Syncthing wasn’t running and the service wasn’t enabled. If you want Syncthing to auto-start whenever the server boots up:

  1. loginctl enable-linger chris
  2. systemctl --user enable syncthing

Reboot the server to verify that it’s working.

(Note that in step 2, the command is most often formally written as systemctl --user enable syncthing.service. If not specified, a “service” unit type is assumed.)

That Digital Ocean article hasn’t been updated in nearly 10 years so it’s best to follow Syncthing’s official documentation instead when manually customizing the config file:

You’ve actually got three unrelated issues. :wink:

For a headless server, a more secure alternative for accessing Syncthing’s web UI is via a SSH tunnel:

In a nutshell:

  1. From your Mac, open a terminal and issue the following command (substituting your Ubuntu server’s IP address, or hostname, in place of x.x.x.x):
    ssh -L 48384: chris@x.x.x.x
  2. After successfully logging onto your Ubuntu server, open a web browser on your Mac and go to to access Syncthing’s web UI on the server.