Constant connection error on slow pc


(Paulo Andre) #1

I have some devices that sync with 2 “central” syncthing nodes, that hold all the files for all the devices (for backup purposes). Both central nodes have the same configuration, but one is on a fast computer and the other is on a (very) slow windows machine. Syncthing works fine, and can handle all those files (almost 200k files, 752Gb), but not the GUI. Every time I open the GUI, unless I’m very fast at pausing all folders, it gives the “connection error” and I can’t do anything. It really seem to be syncthing that can’t handle the requests from the browser. Is there an option to increase the timeout for this error, or reduce the refresh of the GUI, to stop this problem?


(Jakob Borg) #2

You should take a look what the debug console of the browser thinks. Syncthing might possibly be slow in answering the requests on the slow server, but that should not cause a connection error.

Also, I guess, check the logs to ensure that Syncthing isn’t in fact crashing due to out of memory or something. (This is more likely on 32 bit Windows, which it sounds like it could be on a very slow Windows machine.)


(Paulo Andre) #3

The machine is an old 32-bit Windows machine, yes, with 2Gb of memory. But the memory is at 70%, so that’s not the problem. I just confirmed it now, there are no out of memory errors in the console. On the browser console I see a lot of refresh messages, and sometimes “refreshErrors Object { errors: null }”, but apart from that, no other errors I can see. The messages continue to appear even after the “connection error” pop-up, and I can see things refreshing under it.


(Jakob Borg) #4

Then I don’t know, sorry. Browser issue? Antivirus? Proxy?


(Paulo Andre) #5

Can’t be any of those. I use the same browser, antivirus and proxy for the other central node and there is no problem. Why can’t it be what I said, the gui is requesting information too fast from the computer, it is slow, can’t respond fast enough, there is a timeout on the client side and the pop-up appears. That is why I asked if there isn’t a setting to reduce the refresh rate or increase the timeout before the error, I think there was something like this in the advanced settings, but now there’s not.


(Jakob Borg) #6

I’m sure it could, but we don’t have any timeouts like that in the GUI, requests often take a minute or more to complete (the event polling), and we haven’t seen reports of this behavior from anyone else, really… Since we don’t have timeouts in the GUI there is nothing to increase. The refresh rate is “once” as it only loads the current status when the GUI loads and then polls for events, so there is nothing to change there either.

The dialog you refer to pops up when the GUI gets an HTTP or connection error from the other side. You should be able to see that in the debug console, and then we maybe could figure out the cause. Usually it’s something like a proxy or antivirus, assuming again that it’s not an actual error reported by Syncthing itself.


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.