Constant Conflicts of Same Files

I have Syncthing setup between a FreeNAS server and two Windows PCs (A & B). PC A & B is set to Watch for Changes and Rescan every hour, while the FreeNAS has no Watch for Changes (creates issues with all the tiny files that I have) and Rescan every hour. The FreeNAS is really just to Sync PC A and B together when I work at different computers. I am the only one working on these computers, and never simulatiously. I never work off FreeNAS, it is only there to exchange files between PCs and as a sort of pseuso “backup”.

Recently, I started getting constant conflicts of the same files. I will chose which file version to rule, but the same error will keep coming back (maybe at every Rescan)? Something obviously must have happened but I can’t figure out what. Is it my arrangment? I’ve also tried to removing and readding folders on all computers, but it doens’t solve the conflicts. Any suggestion on how to clear these conflicts? Again, I have told FreeNAS how to resolve the conflict but keeps coming back as if it I didn’t chose anything.

image

Because some kind of NAS and Windows are involved, have you tried ticking the “Ignore Permissions” box in the folder’s Advanced tab? This seems to be the usual culprit in such cases.

2 Likes

Thanks. I ticked it on my FreeNAS and so far so good today without errors.