Connection type seems wrong

I have 2 devices on the same LAN I want to set-up. Although I’ve manually specified the address on each instance I see the connection type being reported as “TCP WAN” image

Checked the firewall rules for my sanity but I have “allow all for this LAN”

Any ideas are very much appreciated.

LE: both are docker instances on different machines.

Thanks!

If the two Docker instances aren’t using host networking, they’ll each be on separate private LANs provided by Docker Engine.

In the screenshot, device “Arbiter” is at address 10.10.10.22. Is the other Syncthing device also in the same 10.10.10.x subnet?

1 Like

Indeed they are using “Bridge” mode networking. I wonder why the template I’ve used defaults to this. Physical hosts are on the same LAN&subnet. This is the other guy: image

I’ll give it a shot in host mode. Thanks!

Yup that fixes things. image

Was going crazy thinking it’s due to syncthing’s settings. Although I did have a hunch it might be because they are dockers I did not follow through with debug on that end. Thanks a lot Inspector @gadget ! :grin:

1 Like

You’re welcome! (I’m still looking for a Gadgetmobile) :smile:

1 Like