Connection Error, while syncing, don't know why :/

Hi everyone, and first of all, thanks for your valuable time that you spend on helping others. :slight_smile:

I recently changed from FreeNAS to Ubuntu Server. I use Syncthing to backup the Camera folders from the phones of my family. I installed Syncthing, and when a client is connected, and the synchronization process starts, i get a connection error. Sometimes it disappears for a few seconds, then comes out again. The client status alternate between connnected / disconnected and the folder status synced / out of sync. It sync some files every time, and eventually, makes some progress, but it errors out, and restarting the process. ( or at least seems like to me that’s happening) But, when it’s not syncing (my phone is off), there is no problem at all the GUI is responsive, but when a sync is in progress, the error message comes out.

So, the things I tried, reinstalled the server on the NAS, reinstalled the client app on my OnePlus 6. Disabled the firewall on the NAS. Changed the complete disk’s permissions to 777. Tried a different folder to sync. Tried a different client to sync from. Tried reinstallign it with a snap package. Tried with the default sync folder, that is on the boot drive and not on a mounted disk.

Can anybody help me figure this thing out? I would really appreciate it.

I read on some posts, maybe the errors in the browser console may help to get it diagnosted, so I attach some pictures of it. ( NAS : v0.14.43-ds1, Linux (64 bit) & Android app is the latest)

The error message: error1

The error from the browser’s console that is present all the time, no matter client is connected or not:


The errors that comes out when a client is trying to sync:


Thank You :wink:

Upgrade, possibly using That version isn’t compatible with recent versions, which your androids have.

1 Like

Oh, so the default apt version wasn’t the most recent stable. Just added the PGP keys and the APT source, and it’s now upgradeing. Thanks.

Syncthing only has stable releases :smiley:
Meaning there’s no dedicated stable release, we just release once a month with an RC process for every release to hopefully catch all bad problems.

That looks like the version in debian oldstable. Debian stable is usually already really far behind in terms of Syncthing, oldstable definitely is.

1 Like

Problem solved, works like a charm. Thanks, again. Have a nice day.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.