Connecting to my NAS from outside

So basically, having a workign setup at home between my Macbook and a NAS, once I’m out of the house this whole setup collapses as I have no control over the firewalls of the places I’l be getting internet from i.e. internet cafe, airports, cafes, etc. or did I get this wrong?

If this is correct, that is the big advantage of Bittorrent Sync but then I’d (probably) run into the problems that home user routers have a checkbox: block p2p protocol so not sure its a better solution than Syncthing.

I was looking to simply replace Dropbox with my own secure syncthinggy but it doesn’t look good since I’ve never had any problems using Dropbox from any location.

Anyone care to add a few words to my comment?

1 Like

Make sure your NAS at home is accessible from the outside, by creating a port forward or enabling UPnP and letting syncthing do it, and you’re fine.

OK but what if I’m sitting at a public hotspot? Say I have forwarded the ports for my NAS at home now I can connect to my NAS, what about the other direction, my NAS connecting to my Macbook at the public hotspot where I can’t do any port forwarding?

Does this make sense or am I overlooking the obvious? Quite probable since I’m dead-tired. Will get back to this thread tomorrow and check if it still makes sense to me :blush:

You only need to be able to connect in one direction. Hence, if your NAS is reachable from the hotspot, you’ll be fine.

Weird, syncthign has successfully created the port forwarding on my router => but I still cannot connect if I’m away from home. Might be related to the fact that syncthign runs at home on freeNAS inside a jail but the port gets forwarded to the internal IP of the jail and I can access the GUI from home so can’t figure out what’s going wrong here… Still investigating, any ideas are welcome.

Can you connect to the TCP port at alla from the outside? (telnet your-public-ip 22000 from a Linux or similar box) If not, there’s something in the way and syncthing will be unhappy.

Very weird. Look at this:

BUT its working now. Didn’t change anything except fiddling around, restarting random stuff, etc.

at home but disconnected from wifi, tested using my iphone and syncing worked. case closed. the internet must have had a bad day when I first tried it and then opened this ticket :-/

Btw. the new 0.8.20 version finally fixed all connection issues from my Macbook to my NAS if I was connecting from outside my house :slight_smile: