config.xml not taking effect?

For some reason, the config.xml isn’t applying the gui settings for listening to on my Debian server. f3KiGriEmNpYMnRDyC7WLCRc2GvXdqWS default

But running a netstat, I can see its only listening on

tcp        0      0*               LISTEN      127/syncthing

It is only read on startup, and there is a command line flag to override the GUI listen address.

Thats great. The reason I posted was in hopes to get pointed to the command(s) that I need to invoke to fix it. Thanks

And apparently it’s a common problem:

So after attempting:

gui enabled=“true” tls=“false” debugging=“false”>

The port has remained as 8384. The config file isn’t being invoked.

So if I edit config.xml to use

it works.

If I choose

it just goes to

That issue is a misunderstanding and you seem to have the same one. The GUI listen address is not the same thing as the url Syncthing suggests you might want to click. Both are printed at startup.

A misunderstanding?

When I run the service, the GUI is not accessible.

root@unifi:~# systemctl status syncthing@henrysync.service

  • syncthing@henrysync.service - Syncthing - Open Source Continuous File Synchronization for henrysync

Main PID: 121 (syncthing) Tasks: 15 (limit: 4915) CGroup: /system.slice/system-syncthing.slice/syncthing@henrysync.service `-121 /usr/bin/syncthing -no-browser -no-restart -logflags=0

May 22 05:29:05 unifi syncthing[121]: [F2Z6U] INFO: TCP listener ([::]:22000) starting

May 22 05:29:05 unifi syncthing[121]: [F2Z6U] INFO: GUI and API listening on May 22 05:29:05 unifi syncthing[121]: [F2Z6U] INFO: Access the GUI via the following URL:

Again - config.xml is set to

Can you please explain how I am supposed to access the GUI?

In your case it is indeed listening on

I don’t know what’s going on with your config file etc. though, but I can say it’s not a known or common problem. The issue you linked to is a misunderstanding based on Syncthing saying “listening on [::]:8384, GUI available at”.

Make sure you’re editing the right config file. It’s probably in the henrysync user’s home directory. su to henrysync and run syncthing -paths.

1 Like

So if I manually run syncthing it works.

05:52:57 INFO: GUI and API listening on [::]:8384

05:52:57 INFO: Access the GUI via the following URL:

If I add it via systemctl, it doesn’t invoke the config.xml and it’s not accessible.

That’s basically the issue.

Which user are you running Syncthing as there?

1 Like

Yes that must be the issue, I am running as root when it works.

But I don’t find the config file for user henrysync

root@unifi:/home/henrysync# syncthing -paths Configuration file: /root/.config/syncthing/config.xml

Database directory: /root/.config/syncthing/index-v0.14.0.db

Device private key & certificate files: /root/.config/syncthing/key.pem /root/.config/syncthing/cert.pem

HTTPS private key & certificate files: /root/.config/syncthing/https-key.pem /root/.config/syncthing/https-cert.pem

Log file: -

GUI override directory: /root/.config/syncthing/gui

Default sync folder directory: /root/Sync

You didn’t su to henrysync. You ran syncthing -paths as root. su to henrysync before running syncthing -paths.

1 Like

Thank you!!!

I think what happened was when I ran

locate config.xml 

I hadn’t updated the db yet so it didn’t find the config.xml in the henrysync home folder, but only the default in


For anyone else trying to enable syncthing as a user-run service on Debian, make sure you edit the users config.xml


Cheers thanks!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.