Config file version (37) is newer than supported version (35).


I am using microsoft X64 and downloaded SyncTrazor. I ran SyncTrazor and I receive an error that my file version is newer than supported version.

  1. I uninstall and reinstall with no luck
  2. Next, I open my command prompt [cd “C:\Program Files\SyncTrayzor”] and then type in the cmd prompt [Syncthing.exe -allow-newer-config] but this doesnt work
  3. The command prompt launched a browser based interface. It has messages stating “Automatic upgrade: open C:\Program Files\SyncTrayzor\syncthing9191919191: Access is denied.” I also tried to install from this web interface but got the error “upgrading: open C:\Program Files\SyncTrayzor\syncthing91919191: Access is denied.”" Also no luck

Please help and sorry if this is obvious.

  1. Stop SyncTrayzor
  2. Download the latest syncthing version:
  3. Extract the syncthing.exe from the zip to a local folder
  4. Copy it into your SyncTrayzor installation folder, replacing the current exe
  5. Start SyncTrayzor

I appreciate your response. I downloaded the link your provided and extracted the zipped documents. I deleted the syncthing.exe originally their and replaced it. I still have issues

With that being said, syncthing itself works so thank you for that.

I had the same problem and found the solution on github…

The synctrazer app is old and has an old version of syncthing.exe.

If you already had syncthing installed, it will use your existing syncthing config, but not your existing syncthing.exe.

For me, trayzor installed the old version of syncthing.exe in 2 places:

  1. C:\Program Files\SyncTrayzor
  2. C:\Users<Username>\AppData\Roaming\SyncTrayzor

The second one was where it actually ran syncthing from, so I had to copy the current syncthing.exe there before it worked.

I didn’t need to download the current syncthing.exe since it was already in my syncthing installation folder.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.