Completely disable discovery

Hi there. I was messing a little bit with the discovery settings. Local and global. If I disable both I cannot get syncthing to work. I was reading something about “direct IP address” config. So I thought it should be possible to disable the local/global discovery and just type in the ip address of the nodes. Also the thread below hints that this should be possible. I’ve been trying to setup some ip addresses in the Add Device menu, but they don’t find each other.

https://forum.syncthing.net /t/global-and-local-discovery/2636

Even if you disable global discovery, you can still be available from outside, when you use e.g. dyndns and enter the connection details on the other client manually.

So basically my question is: Can i disable both discovery settings and how can I set things up?

1 Like

If you enter the address or URL of each device they should connect directly with each other. Remember to set up any required port forwarding and firewall rules as well though.

So, we can use “dns names”?

I have DHCP for most of my clients. But, i make sure dnsmasq is setup to resolve their hostnames (for the clients that expose a hostname that is in the DHCP request).

So, i could set this up with just the client machine names? As long as they were resolvable by each client?

Yes. I haven’t tried it yet with hostnames; but given it works with “real” domains just fine, it should work for your setup as well.

So let’s say I have two machines: pc1 10.0.0.1 and pc2 10.0.0.2 I disable all discovery. If I click add device on pc1, entering the IP of pc2 should be enough for the machines to find each other right

1 Like

You are missing the tcp:// and :port part.

2 Likes

Yes!! That works. Thanks a lot.

One more question: Let’s say I want to add a remote device. A PC at the office for example. Do I just add tcp://bla.bla.bla.bla:22000 to the Addresses field? And vice versa with the remote PC.

  • local machine: tcp://10.0.0.2:22000, tcp://45.721.841.85:22000
  • office machine: tcp://87.42.936.851:22000, tcp://87.42.936.851:22001

Something like this?

One more thing about this global discovery feature.
Can I by disabling global discovery on certain devices control the “sync-flow” ?

If you disable global discovery you need to configure your devices to use static IPs or dynamic DNS.

That depends on your setup. If PC1 in your example has a dynamic address on PC3 then yes but if it has a static address then no. PC3 will still be able to connect to it if it has a static IP.

@schnitt Why do you want to disable the discovery services in the first place? This doesn’t do much good security-wise but makes the setup a lot more complicated. And from what you are writing it doesn’t sound like you are familiar enough with computer networks to get it to work flawlessly if your devices have dynamic IPs.

Also, if your goal is to control which devices connect to each other you should probably manage which devices are added to each configuration or which devices each folder is shared with on a device by device basis.

Thanks for the replies.

@generalmanager I want to disable discovery because I only want to connect 3 devices. All the devices have fixed IPs as well as my internet connection at home and work.

@kluppy Thanks. I’ll experiment with the device config a little more.

@schnitt I see, in this case you’ll just have to make sure all the necessary ports are forwarded and the other devices IPs are set on each node as described above. Here the necessary information on which ports you’ll have to forward on your routers: http://docs.syncthing.net/users/firewall.html

This of course means you’ll have to be able to edit the port forwarding rules at work, or they have to have UPnP enabled. This is very uncommon in big organisations, but if you work in a smaller office, it may work.

This isn’t actually true. As long as your work PC can connect to the ones at your home they will sync. Only one side has to be accessible for the connection to be established.

Oh yeah, had a brain fart right there. It’s just going to take a bit longer on average, because only one device can successfully poll. As soon as there are two firewalled devices in different subnets they won’t be able to connect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.