Changing a file name's capitalization on a case-insensitive file system...

…seems to confuse Syncthing mightily. I have two Macs running Syncthing 0.14.39 under macOS 10.12 and 10.13. If I rename a file from “foo” to “Foo” on host A, Syncthing picks up the change and tries to propagate it to host B. In the process, it will create a temporary file “.syncthing.Foo.tmp” on host B, but that’s it – it will never actually rename or create “Foo” on host B or remove the temp file for that matter.

Worse, for one of my folders, Syncthing seems to remember the old capitalization for some of my files even after I’ve manually renamed them to be exactly the same on both machines. It’s now complaining bitterly about “peers who had this file went away, or the file has changed while syncing. will retry later.” This is for a file that it already has an up-to-date copy of, it just happens to have a different capitalization. I’ve tried renaming the directory that the files are in to a totally different name to make it forget the old capitalized files, but that just caused Syncthing to “resurrect” the directory’s previous name and create .tmp files with the old capitalized names in it – and then continue to complain the same as before.

Is there any way to stop this endless madness save for deleting all the index files? I tried removing the folder from Syncthing and then adding it back again but it still managed to somehow remember the bogus files. talks about this

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.