Change the base/home folder (~) on windows

I’ve just installed and set up syncthing to sync between Windows and Android and so far I like it a lot, however, I don’t want to store things in C:/users by default.

This is fine if I create the folders on windows first. However, if I add a remote folder from Android, let’s say, a folder called Notes, it always gets added to C:/users/Lewy/Notes.

I want all synched folders to go in C:/synced so I would like to change the default value of ~ to C:/synced. I’ve been searching through the docs but I haven’t seen how to change this. Have I missed this somewhere?

An even better solution would be, when I add a remote folder, I should be asked where on the local windows device I would like to store it.

This is already the case, unless you have auto-accept enabled.

The tilde character (~) is always placeholder for the user’s home directory. You can however adjust the default folder path, by modifying folder defaults (Actions → Settings → Edit Folder Defaults).


Great, thank you. I didn’t spot this setting earlier. I think there’s some potential for confusion here because “default folder” is used throughout the docs the refer to the initial folder created when you first start syncthing - at least, I was confused!

I was not aware of this setting but I have found it and it is switched off already. However I didn’t get asked where to put the new folders, it just added them straight to ~.

1 Like

When you manually accept a folder, you can always change the suggested folder.

1 Like

I just tested this and it doesn’t seem to be the case. The new folders are created automatically in my default folder (now C:/synced).

Here’s what I’m doing:

  1. Open syncthing on android (Phone-note-10-pro) and add a folder (here I’ve used the default id which was e01gc-obewt), toggle the switch to sync it with my windows pc (MSI)
  2. Open SyncTrazor on windows. The folder immediately starts to sync and is placed in C:/synced. There’s no option to manually add it, everything is automatic.

If I click edit I can see the folder path but I cannot change it:

I understand why I cannot change it once it’s been created so that’s fine. But I am not getting any option to decide where the folder gets placed.

Default folder path I think is set in general settings, not folder specific settings.

It should be impossible for a folder to be added directly if you have auto-accept disabled. Please post logs when that happens. And screenshots of the settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.