Capitalized folders have issues, cant sync after changing case.

Alright, so- im creating a project on a team where I’m sending the newest build of a video game mod to my playtesters via synching; and one playtester is having a lot of difficulty recently. no matter what we’ve tried, he cannot seem to get the sync working. he says that a huge amount of files are being downloaded as 1-byte .tmp files but never turn into the actual files they were meant to be. after a lot of troubleshooting with no fixing, we discovered that the issue may be due to a recent change i made to the files where several folder names that used to be in all caps have been changed to lowercase- this was to fix a bug in the game mod, however, now this playtester cannot sync the files at all for some reason.

Can somebody please tell me a way to resolve this issue?

we’ve tried all of the below:

  • Restarting syncthing
  • restarting pc
  • upgrading synching on my end
  • un-sharing, completely deleting, and then re-sharing the folder
  • complaining to my ISP about blocking his IP (resolved, his IP is unblocked now)
  • disabling his firewalls and stuff
  • re-scanning in synching gui several times
  • giving up mostly and just sending him the build via until we figure this out

the files that fail to sync are very important. they are the textures for the mod; and without them, walls turn into invisible wireframes.

Rename the files/directory to something (entirely) different, let that scan & sync, then potentially rename it back.

i’ll try that and report back i guess. seems like a good idea though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.