Can't start Syncthing on Synology DS916+


#1

I have used Syncthing for months on this NAS and an older DiskStation, with no issues. Recently, I noticed that Syncthing has not run for weeks. When I try to start it from the Package Center, it says “running” for a few seconds, and then says “stopped”. I cannot get Syncthing to keep running. Logging in to the NAS via SSH tells me that Syncthing is at v0.14.23, and attempting to run the upgrade command results in “non upgrade available”. Any suggestions?


#2

0.14.23 is the newest version.

What does the log say? it should say what the problem is.


#3

Where is the log file?


#4

Depends on where the script, starting syncthing, redirects it.

If you start syncthing manually, it will log to stout (the console).


#5

Honestly, I am quite the newb when it comes to the command line and Linux, and I have no idea where to find the log file. If you could point me in the right direction (more specifically), it would help


(Simon) #6

I don’t know about synology, but typically in linux there is two things to check:
Run journalctl -r -u syncthing. If it works but doesn’t show any entries, try journalctl -r | grep -i syncthing, it there is no such command:
Look in /var/log for a syncthing logfile and if there isn’t one, look for syslog or messages at the same location (and to find syncthing related log lines, do something like grep -i 'syncthing' /var/log/syslog).


#7

No dice with any of these suggestions. journalctl -r -u syncthing and journalctl -r | grep -i syncthing both results in command not found grep -i ‘syncthing’ /var/log/syslog resulted in nothing at all

Any other pointers?


(Jakob Borg) #8

You should probably talk to the guy who packaged it for Synology, or a Synology community.


(Adam Piggott) #9

You’ll need to configure your Synology to allow you to SSH into it, guides to this shouldn’t be difficult to find. Do make sure you don’t accidentally allow the SSH port to be available across the Internet.

I’ve changed the settings the Package Manager used so this may not be correct, if so just let me know :slight_smile:

The logfile should be saved at /usr/local/syncthing/var/syncthing.log You can copy this to one of your user-readable folders, this command should probably work, replacing “foldername” with one of your shared folders: cp /usr/local/syncthing/var/syncthing.log '/volume1/foldername'


#10

Unfortunately, I can’t seem to access that directory - permission denied.


(Adam Piggott) #11

You may need to prefix the command with “sudo”, or login/switch to root once logged in.


#12

I tried that. Even though I was logged in as an Admin, when I tried to switch to the root account or issue commands with a sudo prefix, I received a permission denied message. I am really stuck.


(Adam Piggott) #13

I don’t really want to start directing you to try anything else, lest we screw something up. Is it feasible for you to uninstall Syncthing and re-install it? It’ll mean setting the device up on other remote devices again (new device ID, certificates), and setting up shared folders, unless you can copy out the other files, though :frowning:


#14

Actually, that is exactly what I did. However, what I discovered is that when I reboot the Synology (not because of Syncthing - had to reboot because of another install), Syncthing does not start automatically, and I am back to the same problem that I started with, where I cannot get Syncthing to start at all. Is the only solution going to be to reinstall Syncthing every time I reboot the NAS?


(system) #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.