Can't remotely access GUI on Windows

I want to access the syncthing-gui of my windows-installation remotely. But I’m not sure why it’s not working.

I set the GUI listen address to ‘0.0.0.0:8384’. I’ve also enabled insecureAdminAccess

image

I also get the ‘WARNING: Insecure admin access is enabled.’ message. However, I just can’t connect to it. Not even from the same machine while using it’s IP/hostname (‘localhost’ still works though)

The logs also keep saying it’s just listening on 127.0.0.1 even though I switched it to 0.0.0.0

image

I also tried changing the address in the config.xml and starting starting syncTrayzor afterwards. The syncTrayzor settings still correctly show the address I typed into the config-file, but it’s still only listening on 127.0.0.1

apparently it doesn’t care for what the address-config is at all. I can’t even change the port. It’s always on localhost:8384.

I also tried running it as admin and disabling the firewall

IIRC, there’s a setting in Synctrayzor for the listen address as well as in Syncthing. Check both.

1 Like

Wow thank you. I was going crazy. Didn’t realize it has its own separate settings page.

So there are basically 3 different settings pages?

  • Action->Settings
  • Action->Advanced
  • File->Settings

That’s some UX-nightmare

Syncthing only has one setting, which you can access in the settings dialog and the advanced dialog, which shows all settings in a raw manner.

However this can be overridden from the outside, by another program launching Syncthing such as synctrayzor.

When it is overridden Syncthing says something about that in the settings dialog I think.