Can't login to Syncthing GUI with Ngnix Proxy Manager

I can login using the local IP, but when I route that with Nginx, It won’t.

I have the GUI listen address as :

I’ve been googling for hours but I can’t find anything, In browser console it says

Failed to load resource: the server responded with a status of 403 () Refused to execute script from '' because its MIME type ('text/plain') is not executable, and strict MIME type checking is enabled.

No special setting in browser about http/https autoswitch?

Syncthing GUI forced HTTPS?

How can you local login to ip:9900 when GUI is set to any:9001 ???

Are you setting the following HTTP header?

X-Content-Type-Options: nosniff

Nothing special set up, I tried multiple browsers.

Sorry i meant

No, should I?

Could you share your nginx config?

Omg it’s working now finally.

When you asked that, I was writing that it’s nothing special on the GUI and went to copy paste everything here.

I had these three things checked, Cache Assets, Block Common Exploits, Websockets Support.

Block Common Exploits, reminded me of something I have found while searching for hours to fix the problem, something about identity protection addons on the browser might cause that.

Long story short I disabled the three things and it just worked.

Thank you so much.

1 Like

The UI should work without content type sniffing. That looks like a bug on our end.

1 Like

Thank you so much for your follow up and support and taking the time for everything.