Can't connect remotely to WebUI

I’m using the version 0.13.10 on a Linux mint machine.

I can only access the WebUI on my local network, if I try in any other it doesn’t work. I have already opened the port(39280) in the firewall and my router firewall isn’t active. What else have I forgot? I have qBittorent WebUI set up on port 8080 and it’s working fine, so it must be something not configured right.

Maybe you forgot to forward the port in the router?

By the way, if you already have remote ssh access to the machine, forwarding the WebUI port over ssh is often an easy and secure option. You don’t have to configure port forwards or firewalls and it’s encrypted by default.

I have not added qBittorrent port(8080) in the router though. And I tried to add the 39280 port but it didn’t work.

I did a quick setup of a ssh server, but I don’t know what to do next. Do I just forward the ssh port to the syncthing port?

You can use SSH port forwarding to configure the GUI remotely. Assuming your remote Syncthing instance offers the GUI on port 8384, try something like this:

$ ssh -L 9384:127.0.0.1:8384 remote-server

Then, you can point your local web browser at 127.0.0.1:9384 and configure the remote machine.

Is that really the GUI port? Not the sync port?

Did you change the gui listen address from 127.0.0.1 (local only) to 0.0.0.0 (everywhere)?

Sorry for the late reply

[quote]Is that really the GUI port? Not the sync port?

Did you change the gui listen address from 127.0.0.1 (local only) to 0.0.0.0 (everywhere)?[/quote]

Yes, I have this in the config file:

I did this, I can log in locally but not remotely. Now I have two local ports to acess the WebUI but none that works for remote access.

Of course, you also have to forward the ssh port if you want to access it from outside the local network. But that was just a suggestion in case you already had a working ssh setup.

In either case, you need a port forwarding rule in your router unless your server has a public IP address. How it is set up depends on your router model and you should consult the router’s manual or search for the instructions online.

It seems the problem was in the router settings, I can acess now. Thanks for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.