Cannot sync Linux with Android

Hi Syncthing team! Thanks to your app.

Both devices have Syncthing v1.20.1 Synchronization works well only inside local network (i.e if I connect Linux to wi-fi hotspot of the Android device) Firewalld is installed on Linux computer, so I add Syncthing to exceptions. On both devices I see only 3/5 discover servers:

(If I turn on VPN, will be available) Logs from Linux: log.txt (26.9 KB) On Android I have almost symmetric logs. Why I cannot sync my devices?

Normally, you need global discovery to work if you want to make devices connect outside of your local network. According to the screenshot, global discovery isn’t working though, so I can only suggest to check the firewall again…

If I understand correctly, do you mean that global discovery works only when the VPN is on, and doesn’t work when it is off?

1 Like

Thanks for attention. Global discovery should work over global@, but I not see that. In my situation global discovery not work properly, just 1/3 global and 2/2 local endpoints online:

And yes, if I enable VPN, then global@ become online

Also without VPN I can ping

$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=56 time=61.4 ms
--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 61.367/61.367/61.367/0.000 ms

But curl show nothing:

$ curl --connect-timeout 7 -k
curl: (28) Failed to connect to port 443 after 5263 ms: Connection timed out

Yeah, normally you should see at least something like this.

For the record, the commit 992bb0a98cad92b78cfcaea5dd95673349143bad explains differences between the three types of global discovery (note: this information should really be included in the Docs :pensive: it’s under

My networking knowledge is very weak, so I probably can’t help more with finding the culprit and/or solution to the problem here. Maybe someone else will chime in to provide more feedback.

1 Like

Wow, this is mean that I have no global discovery at all, because I must have v4 or v6 at least? If this is true, I now understand the reason of malfunction of discovering.

Something (most likely firewall) is preventing connecting to discovery servers, you need to fix that.

1 Like

Faced the same problem. Lost connection at one point on multiple devices of the same provider. Device connection problem

@AudriusButkevicius, I turn off the firewalld but discovery status not changed:

Firewalld status:

$ sudo systemctl status firewalld.service
[sudo] password for root:
○ firewalld.service - firewalld - dynamic firewall daemon
     Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: di>
     Active: inactive (dead)

I live in Russia, may be this is a reason of not accessible syncthing servers? I noticed issues with access to this forum with disabled VPN.

Apparently so.

I read Blocked IP addresses in Russia - #33 by schnappi, and after that I tried manually add as global discovery server. I’m getting error with message: global@ Post "": x509: certificate is not valid for any names, but wanted to match


Can I fix that? Or, may be, is there other worked out-of-the-box global discover servers?

Now this issue solved. Looks like Russian providers allow https connections to Syncthing discover servers

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.