Cannot sync b/w android and storage media

  • Hardware setup: External storage media <—USB—> Pioneer FreedomBox <—ethernet—> router.
  • Software: Running Debian GNU/Linux 11 (Bullseye) and FreedomBox version 21.4.

Hello everyone.

Setup: I attached external storage media to Pioneer FreedomBox. I used SSH to enter into Pioneer FreedomBox, created empty “test” folder (Send & Receive) in external storage media, then created empty “test” folder (Send & Receive) in Android. Pioneer FreedomBox and Android devices recognized each other, and the folders recognized each other.

File originally in Android: But when I placed one file into Android “test” folder, Pioneer FreedomBox “test” folder seemed to recognize there’s a file, but does not sync. Pioneer FreedomBox “test” folder said “Out of Sync,” and under “Out of Sync items” lists 1 file of 205 KB (the correct size of the file).

File originally in external storage media: Then, I created a text file in the “test” folder of the external storage media attached to the Pioneer FreedomBox. The text file appeared in the Android “test” folder, but the files in the Android test folder still did not appear in the external media’s test folder.

My guess about problem: This leads me to believe I have the correct paths of each folder, but there’s still some issue about writing to the external storage media. I’ve tried creating empty .stfolder text file and empty .stfolder directory in external storage media but still no success.

Any thoughts?

You need to make sure that the user running Syncthing have proper access to the hard drive. You might find better help with that in a forum for Pioneer FreedomBox.

I asked in the Pioneer FreedomBox forum but they told me to ask here.

Please share screenshots with the folder expanded.

I think I may have found a solution.

Files created in external storage media appeared in android, but files in android could not appear in external storage media. So, as @martinleben said, there had to be some kind of write permission issue.

I tried:

sudo chown -R syncthing:syncthing /media/root/{external storage media name}/

This did not work. Then, I tried:

sudo chown -R syncthing:syncthing /media/root/{external storage media name}/test/

This did work.

My thoughts: I thought that giving syncthing permission to higher level directory would automatically give permission to all lower level directories. Apparently that’s not true? I guess I had to give permission to each directory manually. I’m still confused b/c I tried chown before and Pioneer FreedomBox said you don’t have permission to chown. I dont know why chown worked this time. I feel like there’s something obvious I’m missing. Anyway, I’ll let you know if I get errors again. Thanks everyone.

2 Likes