Cannot Connect GrapheneOS and LinuxMint

I’ve used Syncthing for a while, but as of a week ago, I cannot get my phone and laptop to sync with each other, no matter if I install the latest versions of the software on each, or manually make them forget each other and re-add them to each other.

My phone is running GrapheneOS, with Syncthing v.1.14.0 from F-Droid, and my laptop is running LinuxMint with v1.14.0

Any Advise?

Firewall, Virusscan, Malwaresoftware, closed Router Ports etc. It seems around.

Did you check the logs on both sides?

I found something interesting on the phone log: “NAT Type: Restricted NAT”, and corresponding to that on the laptop log: “NAT type: Port restricted NAT”

is that normal?

That’s just the output STUN which tells what kind of NAT it detected.

Could you post redacted logs of both sides?

What are examples of log entries pertinent to privacy privacy that I would want to redact?

Public IP addresses and Syncthing IDs if you uncomfortable posting them in the forum.

Attached are three logs. One from Laptop, and two from phone. Strangely, phone produced two logs, one through the regular Syncthing app, and then another when using the WEB GUI.

android_grapheneOS_Log.txt (4.0 KB) LAPTOP_LOG.txt (2.5 KB) Phone_Web_Gui_Log.txt (2.1 KB)

Could try to enable global discovery on your phone?

Enabling global discovery solved the problem, thank you!

Why should that make the difference?

Did you update to Android 11? The app has still has problems with local discovery on that Android version.

@bt90 already addressed the concrete question. On a more general note:

Asking people to use time to help you with your problem, and not indicating that you changed default settings, is not helpful and quite disrespectful of their time.

And regardless of asking for support or not: If you don’t understand what something does, don’t change the defaults.

1 Like

Blockquote Did you update to Android 11? The app has still has problems with local discovery on that Android version.

Yep. Android 11 via GrapheneOS. That makes sense now :slight_smile:

Imsodin,

I was not aware that I had changed the default setting.