Cannot connect devices between 5Ghz wireless band and Ethernet PC.

Hi, I’m having a strange issue where I can sync my pc (ethernet) and my android device (wireless 2.4Ghz) in my LAN configuration without any problems (Although the speed is really slow, like 20 - 90 Kb/s), but when i change to 5Ghz wifi band on my android, my pc cannot sync to it, i receive “i/o timeout” for TCP connection. The strange thing is that both the devices can discover each other using the broadcast function of the local discovery, but when it comes to sync, they simply refuse to do it. I tried to solve this by myself, but I noticed that I can’t even ping the remote device, neither in the pc nor in android.

I’m using Syncthing v1.27.0 on my PC and Syncthing-fork v1.26.1 on my Android device. I use it only with Local Discovery enabled on both devices. My LAN network is behind a NAT, and devices are under the same subnet. I already checked my router config for “Client Isolation”, and it is disabled, i enabled it, restarted the modem, disabled it, restarted again, and nothing. I also tried disabling pc firewall, do port forwards, assigning static ip addresses, changing dns provider, blocking channels of the 5Ghz band, enabling Upnp both in router and syncthing, and nothing again (The only thing that i know and didn’t do is reseting the router)… I can access the internet and use relays or global discovery normally, the issue is only when trying to connect the devices under LAN with the 5Ghz band.

The tests that i already did (all in LAN only):

  • Ethernet pc -><- phone 2.4Ghz Wireless = works both ways!
  • Ethernet pc -><- phone 5Ghz Wireless = neither ways works.
  • phone 2.4Ghz Wireless -><- phone 2.4Ghz Wireless = works both ways!
  • phone 2.4Ghz Wireless -><- phone 5Ghz Wireless = neither ways works.
  • phone 5Ghz Wireless -><- phone 5Ghz Wireless = works both ways!

Is this a expected behavior? Thanks for your patience!

Syncthing, along with most other network apps, just see a network interface and not the physical medium that carries the network link, so they really don’t know if it’s wired, 2.4GHz, 5GHz, or two cans with a piece of string. :smirk:

For wireless routers that support it, there’s “client isolation” which separates each client’s network traffic similar to a wired network switch. But those same routers also often support LAN isolation – i.e., there might be a 2.4GHz network with the SSID “24GHz”, a 5GHz network named “5GHz” plus a “2.4GHz Guest” and a “5GHz Guest”. Usually clients in the “24GHz” network can talk to clients on the “5GHz” network while the “2.4GHz Guest” and “5GHz Guest” networks are isolated islands.

So if I were to make an educated guess, network bridging between your wired/2.4GHz and 5GHz LANs is disabled. Check your router settings for a “WLAN Partition” or something long those lines.


Thanks for your insights. I searched for configs related to that but my router (Nokia G-240w-G) has neither “WLAN Partition” nor “guest WLANs”. Maybe it is a configuration made by the ISP? or maybe the firmware or the router model is bad configured and buggy?

Surprisingly difficult finding a copy of the users manual for the G-240W-G. Hopefully the ones for G-240W-C and G-240W-F are close enough.

It’s a fancy fiber modem/router, so no wonder it doesn’t have simple toggles for guest Wi-Fi and LAN partitioning. There’s VLAN support and also a bridge/route setting for each Wi-Fi SSID.

Compare the SSID settings between the 2.4GHz and 5GHz LANs. Is one set to “bridge” and the other set to “route”?

Unfortunately there isn’t this option in the G-240-G for both WLANs. My guess is that it’s a firmware problem, maybe I should contact my ISP. Thanks for your attention anyways!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.