Cannot access web GUI after creating GUI user and password

#1

Had syncthing running fine on FreeNAS machine. Did not like the Not Secure warning in the web browser so went to settings, created a GUI authentication user and password and ticked “use HTTPS for GUI”. Now attempts to reach GUI connects to https://localhost with message “This site cannot be reached”. I assume this is because the instance of syncthing I am attemping to access is not on my windows pc, but on the freenas device.

Any suggestions on correcting this problem?

#2

Are using the port in your browser? https://localhost:8384 If you have not setted another port, this is the standard one.

#3

if i enter https://localhost:8384 in my browser, it connects nicely to the syncthing on my windows pc. I need to connect to the syncthing on my FreeNAS device. I suspect i need to make changes to the config.xml file, but have no unix/linux experience and am unsure how to open or edit that file.

(Evgeny Kuznetsov) #4

If you have already connected to your NAS’ GUI in the past, its GUI must have its listening addresses set up so that you can connect to it from your network. Try https://xxx.xxx.xxx.xxx:8384 (where xxx.xxx.xxx.xxx shoud be the IP of your NAS). You can look it up by expanding the NAS section in “Remote Devices” part of GUI on your own machine.

#5

If you want to connect from your Windows PC to your FreeNAS device, set in Action -> Settings -> GUI 0.0.0.0:8384 to the GUI Listen Adress. This way your FreeNAS device will get to an accessable remote device. Then you can access with the correct password and the IP, which is mentioned here Cannot access web GUI after creating GUI user and password to your FreeNAS.

#6

Tried as you suggested. Unable to connect to site using two different browsers. Chrome: “This site can’t be reached. xxx.xxx.x.xx refused to connect.”
Bing: “This website could not be found. Error code: INET_E_RESOURCE_NOT_FOUND”

#7

twy

I believe changing the GUI listen address on my windows pc syncthing would allow remote access to its GUI. I need to change the GUI listen address on the FreeNAS syncthing, but cant do that through the GUI since it is not accessible.

(Evgeny Kuznetsov) #8

It would seem so, yes. You can change it by editing config.xml (if you can access it directly), it is listenAddress parameter in options section.

Beware though: you need to stop Syncthing before you edit config.xml.

#9

I will query the freenas forum on how to access/edit the config file. Thanks.

(system) closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.