Can not connect from outside


I set up syncthing with a raspberry pi, 2 laptop, tablet and a mobile phone. Everything works like a charm when I am in my wifi network.

When I am outside my network I can not connect from my phone to my raspberry.

On my raspberry “global discovery” an UPnP ist activated. I can see in my router that UPnP works.

TCP, 58916, raspberry-pi,, 22000

What is wrong with my configuration? Here my configuration on my raspberry.


Have you actually tried connecting to that port from the outside, to see if it gets mapped correctly?

Seems to be open

nmap -sT -p 22000 myIP

Starting Nmap 6.40 ( ) at 2014-12-10 17:17 CET Host is up (0.0050s latency). PORT STATE SERVICE 22000/tcp open unknown

Nmap done: 1 IP address (1 host up) scanned in 0.06 seconds

I mean from the outside. Basically, is port 58916 being correctly routed by your router? Also, you might want to run STTRACE=discovery to see if the outside node gets the correct IP for the router.

Hi, I really appreciate your help. But I am just an “user” and dont really know what you mean.

I will try a connection from outside with my laptop tomorrow.

Just a question. Which would be a manual port forwarding setup, without UPnP.

from port xyz1 to port xyz2 on raspberry port 22000. What would be “xyz1” and “xyz2”

Hi again,

I check with my laptop (tethering via mobile) and it works. It can connect to my raspberry.

But the mobile can not.

Here is the mobile config found in

< options> < listenAddress>< /listenAddress> < globalAnnounceServer>upd4://< /globalAnnounceServer> < globalAnnounceEnabled>true< /globalAnnounceEnabled> < localAnnounceEnabled>true< /localAnnounceEnabled> < localAnnouncePort>21025< /localAnnouncePort> < localAnnounceMCAddr>[ff32::5222]:21026< /localAnnounceMCAddr> < maxSendKbps>0< /maxSendKbps> < maxRecvKbps>0< /maxRecvKbps> < reconnectionIntervalS>60< /reconnectionIntervalS> < startBrowser>true< /startBrowser> < upnpEnabled>false< /upnpEnabled> < upnpLeaseMinutes>0< /upnpLeaseMinutes> < upnpRenewalMinutes>30< /upnpRenewalMinutes> < urAccepted>-1< /urAccepted> < urUniqueID>< /urUniqueID> < restartOnWakeup>true< /restartOnWakeup> < autoUpgradeIntervalH>12< /autoUpgradeIntervalH> < keepTemporariesH>24< /keepTemporariesH> < cacheIgnoredFiles>true< /cacheIgnoredFiles> < progressUpdateIntervalS>5< /progressUpdateIntervalS> < symlinksEnabled>true< /symlinksEnabled> < / options> < / configuration>

How can I run “STTRACE=net,discover syncthing &> syncthing.log” on my android device?

I think you need to set the debug options from the UI and then download some log inspector (if your device is rooted), otherwise use adb (google logcat android howto)

I found the solution.

Global Discovery did not work correct.

I just had to change “udp4://” to “udp4://” on my android devices. Now it works!

That should already have been the case if you were running the Android app? But this was homebrew maybe?