Blank SyncTrayzor GUI Windows 10


(Tim) #1

Dear All,

I am using SyncTrayzor to sync files between two Windows 10 boxes (I also have a Macbook syncing with these two computers, but I’m not using that at the moment.)

Windows Box #1: Windows 10 version 1709 Windows Box #2: Windows 10 version 1803

On Box #2, the SyncTrazor GUI is entirely blank. Syncthing is still running (files are syncing in the background), but the main GUI is blank, as is the ‘Settings’ GUI. I can see SyncTrayzor popup when I click on the icon in the Windows task bar on Box #2. On Box #1, everything is fine.

I’ve tried re-installing syncthing on Box 2. Problem remains. I did not do an uninstall first (How is that done btw?).

I am using v0.14.47 on box #1. I should be using that on Box #2 as well, but I can’t verify in the GUI of course.

This might be related to the update if Box #2 to Windows 1803, although I am not entirely sure.

Any suggestions?

Many thanks Tim


(Antony Male) #2

Obvious thing to try: View -> Refresh browser.


(Tim) #3

Hi Antony,

Thanks for the reply.

I’m sorry for not being clear, but even the menu bar with the choices of ‘File’, ‘Syncthing’, ‘View’, and ‘Help’, aren’t even showing up. The GUI is blank from edge-to-edge. Windows is not even doing a paint refresh on the whole thing.

I should add that this is specific to Syntrayzor. All other programs, both native dessktop applications or W10 universal apps are working fine. What GUI toolkit is Synctrayzor using?

Tim


(Antony Male) #4

That’s weird. It’s just using a standard .NET toolkit (WPF), all that’s needed is .NET 4.5.2 or above (which the installer will install for you).

Googling around, it looks like some display drivers can be the cause of similar issues?


(Tim) #5

Yes, it is very weird. I verified that I have not updated the display driver. (I did update the BIOS - but I don’t think that could be it. This is a ThinkPad T450s running Windows 10 Pro x64.)

I don’t know if this is useful information, but I can access sub menu items by clicking in the right place on the menubar. That is, if I click where ‘Syncthing’ should be on the menubar, the submenu with ‘Start’, ‘Stop’, ‘Restart’ etc… is now visible.

For now, I can select "Open in external browser’ in the Syncthing submenu and work from the browser interface. It would be nice to have the SyncTrayzor GUI working, but this is a suitable temporary work-around.

If there is anything you would like me to do to provide more actionable information, please let me know.

Tim


(Robert Carter) #6

I would like to add i have a similar problem with Synctrayzor but it is in Windows 7 pro 64bit and i still get the menu bar but the rest of the ui is blank. The only fix i have found is to reboot the computer. Ending the process and restarting Synctrayzor does not fix the problem only a restart does.