Best way to prevent syncthing from upgrading automatically

Hey there,

Since the -no-upgrade argument has disappeared from the cli I’m not sure what is the proper way to prevent syncthing from upgrading automatically. I inspected the source code a little bit and it seems if I pass an empty value in the -upgrade-to argument it has the same result. Could you confirm this? If no, how can I achieve this?

Thanks, Gabor

There is a dropdown in the settings menu to disable upgrades. Is the complexity of that too low to be used?

export STNOUPGRADE=1 is another option

Did we ever have this?

Sorry, I don’t use the GUI at all, since I wrote an own frontend on the top of the ST. I need to adjust this from the cli or through the REST API. But I guess if there is such an option then it’s viable through the REST API. I’ll do the homework!

Thanks! :slight_smile:

Okay, now I see that there is an “upgrades” config parameter and by setting that I can achieve the desired result. However I cannot find anything about it in the latest docs. Should I send a PR or will you fix it?

I don’t know which parameter you mean. The upgrade setting in the config is autoUpgradeIntervalH, search for it here:

When I adjust the auto-upgrade the config is updated with this parameter:


Ah. That’s some extra attribute used in the GUI which apparently leaks into the config post. :man_shrugging: You want the one I mentioned.

Yeah, you’re right. Thank you guys! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.