Basic install question on cluster formation in Redhat

I have 10 Redhat servers however for simplicity I have configured 3 servers , where I have installed syncthing and ran it and it configured the config.xml . I then ran the same command on other 2 servers and was able to get to the GUI of the first machine and add the other 2 devices , however they are showing disconnected ? Am I missing a step ? Do I need to open the GUI for each server and then do “add remote device” ? Do I need to add an “introducer” if so how ? Appreciate any help

Have you set up and shared at least one folder?

Yes, it does sound like it.

Yes, without an introducer in the mix…

If you’re frequently expanding the cluster and/or have a lot of shared folders that are added/removed, it could ease the setup, but whether it’s necessary depends on the user and the setup.


Thank you @gadget but something is not right .

a) I removed all prior .config directory and ran syncthing on both hosts 
b) Accessed UI from Server1 and clicked Add remote device and put the Device ID and saved . I am using default directory so checked that in both the servers
c) I now logged into UI of Server2 and did the same steps . 
d) Restarted syncthing on both 
e) Device still shows DISCONNECTED 
f) I copied a text file to share directory ...nothing happens . 

What am I missing here ? I even created a new directory on both hosts and tried and it did not work . So Is my understanding correct that if I share a directory on both hosts say /opt/test/Sync and dropped a file in that directory then if I go into the other server to /opt/test/Sync the file should be there ?

If they are not able to connect you are probably missing a firewall opening or something similar.

Hmm…I checked and no firewall or iptables running . I can login to each of the hosts GUI and see that folders are up to date but the files are not copied andd when I see Remote Device Status it shows "DISCONNECTED " and “Last Seen” is NEVER which tells me the clsuter never formed .

Is there any port I can check between these 2 linux hosts ? Any help appreciated .

@gadget I tried NC from each host to the other host:22000 and it connected fine

nc -zv iphost1 22000

I was about to say port 22000, firewall-cmd and netcat, but you already took care of that. :grinning:

Is Syncthing installed from Red Hat’s repo or the standalone binary from Syncthing’s GitHub page?

Are the servers all on the same subnet? And if they aren’t, is global discovery enabled in Syncthing?

@gadget I figured it out. It was the IPv6 that was causing the problem and “nc” showed the issue . After I added the “tcp4://hostname” instead of dynamic in the DEVICE section they started talking again . Appreciate the pointers