bad certificate warning between PC and VPS


For personal use I have set up syncthing (0.10.21) on my VPS (Ubuntu 14.04) and home computers (OS X and laptop OS X) which works like a charm. Really loving what you’ve made.

To further extend my use I tried to set it up on my work computer as well (windows 7, 64 bit) but I ran in to a problem I don’t fully understand:

Because I’m behind some firewall (I have administrator rights on my local machine) I tried to connect only to my VPS. At first, the two devices didn’t connect. From the server side the PC device status was not connected, and from the PC side, the server device was unused.

In my (rather symplistic) attempt to fix this i set the address for the server device (in the PC web GUI) from dynamic to the actual ip address with :8080.

However, after I did that I got a prompt telling me another device was trying to connect (with a different syncthing ID than the server). I allowed it but din’t share any folders with it (out of fear I guess). After seconds, I got the following error (in the web GUI of my windows PC):

12:12:34: Bad certificate from 3VODII (XXX.XXX.XX.XXX:8080): x509: certificate is valid for ABC, not syncthing

where XXX = the IP address of my server and ABC = the name of the Digitalocean droplet.

Some more info: when I start syncthing on my PC, it says *Starting UPnP discovery…UPnP discovery complete (found 0 devices). After starting local and global discovery announcements it prints the same warning stated above every 60 seconds. I have opened port TCP 22000 and UDP 21025 I can access my VPS using putty with SSH but without tunneling (so it isn’t a firewall problem per se I think?) Same error in firefox and Chrome (if that is useful at all)

It is still weird that a new device was created, or am I missing the point completely? If anyone has some advice or help to offer, it would be greatly appreciated!

Thanks in advance!

8080 is used for web UI 22000 is used for the actual transfer protocol