Autostart syncthing fails

Hello guys

I tried to use “sudo systemctl enable syncthing@username.service” to start syncthing automatically

Symlink was created successfully

When i run “systemctl status syncthing@username.service” i get “failed userID 217” something like this

I wasn’t sure at first what username i was supposed to use (ubuntu username or syncthing username), but i used the syncthing username (the one for the GUI) after the syncthing arch wiki page referring to the “actual name of the syncthing user”.

Was this correct?

Or is it because the username i used for Syncthing has no HOME directory?


It’s syncthing@<username for which you want to run syncthing>.service Regardless, you can check the logs of the failed service to see why it failed, and yes, that usually needs a home directory to store config and what not.

thanks for your answer… i now used the ubuntu username (since that one has a HOME folder)… still no luck.

now it says “(code=exited, status=1/FAILURE)” which according to the webpage is just ERROR.

i don’t know if i have to remove the other symlink. if i only knew how to do that LOLOL

“systemctl status syncthing” gives me nothing

could you please assist me?

You need to check the logs of the service.

There is plenty of information on the internet about systemd and how to check the logs, sadly I don’t remember the commands by heart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.