Autostart on Manjaro

I’m trying to figure out how to autostart Syncthing on my laptop that runs Manjaro. I’ve already tried the methods listed in the docs. I couldn’t find Syncthing-start.desktop.

There’s a link in those docs pointing at it:

Same problem here (Manjaro). The syncthing-start.desktop-file is just not where the docs say it should be, so it can’t be copied to any other place. Any help troubleshooting appreciated. I formerly used Syncthing-GTK, worked without problem. Syncthing is also not listed in the options of the GNOME Tweaks autostart, so GUI has the same problem. In fact, only way to start it is via Terminal, the browser GUI does not get a connection to my other device unless I start Syncthing in a browser-session beforehand. Any guesses?

The file is where the docs say. Can you please walk me through the steps there and tell me what you do: Starting Syncthing Automatically — Syncthing v1 documentation

Well I looked at this part of the docs: Starting Syncthing Automatically — Syncthing v1 documentation

After I can’t find Syncthing in the Autostartmenue of Gnome Tweaks, I looked for etc/linux-desktop/, which does not exist. Then I looked in /usr/share/applications/, which does not contain a file named syncthing-start.desktop, nor any other file containing ‘Syncthing’ in its name. So yeah, it’s really not there. What can I do?

That’s a relative path - where did you look exactly? Quoting the docs:

Find the file syncthing-start.desktop: Either from the package you downloaded from GitHub in etc/linux-desktop/ […]

Assuming you downloaded from our website or github, that’s expected:

[…] in /usr/share/applications/ if installed from your package manager.

That’s a relative path - where did you look exactly?

I meant /etc/linux-desktop/ Where should I have looked instead?

Doesn’t exist on my machine. cd: no such file or directory: /etc/linux-desktop/

I didn’t download from Github, but just used the package-manager with sudo pacman -S syncthing, as stated here: Community Contributions — Syncthing v1 documentation

That was the missing information - you didn’t download from Github, so the first part doesn’t apply to you. Then you should file a bug with the Arch community repo, requesting that they install those files to /usr/share/applications/. And for now get the files from the link in the last part of the docs:

For more information relating to .desktop files e.g. for application menus, refer to

I’ll adjust that to say that it’s not only about more info, but that you also can find the files there:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.