Autostart on Android

Great system but have to start manually each time on both my Huawei Mate 10 Pro (Android 10) and Lenovo Yoga Tab (Android 11) On the Huawei I have “Start automatically” checked but it does not start - it is set to run all WiFi networks. On the Lenovo that option is also checked but I have set it to run only on my home network - it says the SSID is not recognised even though it showed that SSID when I configured the app! When I tell it to run on all networks it does auto-start

Please make sure Syncthing is allowed to use location all the time (i.e. not only when when the app is open, etc.). How to do it is different depending on the Android manufacturer, but if you haven’t been asked when running the app for the first time, please check permission-related options in the Android settings.

Location permission is required in order for the app to be able to check the SSID of the currently connected network.


A bit offtopic, but I just recently I solved a similar issue on just that phone that OP mentions, but could not quite figure out how that is connected. (Thanks @tomasz86 for the explanation!)

So I had to enable “Location Services” - not only for the app that was affected in my case, but for every app on my phone

Thanks - that seems to have solved the problem on both my devices

A bit premature - has fixed the issue on my Lenovo but the Huawei remains a problem - seemed to work yesterday but when I started this morning nothing. Will try Arneko’s fix when I have the time…

Let me clarify:

I had an app that relied on scanning for bluetooth devices in the area, that hasn’t been working for years on my Mate 10 Pro. Just recently I found that activating “Access my location” (Settings->Location->“Access my location”) got this other app to work, and I think that can be explained by @tomasz86 post, as I believe it applies to bluetooth just as much as to wifi (although, my country’s “Corona” app worked flawlessly, which I suppose works on a similar principle)

This setting is not a “per app” setting, but has to be enabled globally. I am not sure if it helps you with your issue, but I know that getting that phone to autostart or “not kill” (or not delete) something can be a pain.

I do not autostart syncthing on that phone, as I use it only “on demand”, so I can’t really comment on that. But:

You may want to check the battery settings on the preinstalled “optimizer” app. You want to set syncthing to “Manage Manually”, I believe, otherwise EMUI will kill it.

Thanks for the update. I already had “Access my location” enabled. I have just changed Syncthing to Manage Manually in the battery settings and restarted the phone and it is working, so I hope that finally this is solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.