Arm V5


(Bruno) #1

Hi, I’d like to know if the arm version of syncthing should be able to run on an old armv5tejl from a nas. Running fine from my qnap, I revive an older nas to have a try. But at start, I get a

[root@WHITEBOKS syncthing-linux-arm-v0.14.42]# ./syncthing

Illegal instruction

[root@WHITEBOKS syncthing-linux-arm-v0.14.42]#

Not to digg if it’s useless, should it run and do I have a bug or is it to old ? Thanks,


(Jakob Borg) #2

We used to set GOARM=5 which should mean it should run. But apparently current builds are with the default value, ARMv6. I think that’s unintentional.

But I don’t know if that would fix your specific issue, arm versions are a bit magic.

See if this build works any different: https://build.syncthing.net/viewLog.html?buildId=15229&buildTypeId=Syncthing_BuildLinuxCross&tab=artifacts


(Bruno) #3

Thank you ! I tried and get the same result :

[root@WHITEBOKS syncthing-linux-arm-v0.14.43-rc.1+8-gdb03562]# ./syncthing

Illegal instruction

[root@WHITEBOKS syncthing-linux-arm-v0.14.43-rc.1+8-gdb03562]# But never mind, I’ll maybe digg later :slight_smile:


(Audrius Butkevicius) #4

I don’t recall exactly but I think Go dropped support for ARMv5 some versions ago.


(Audrius Butkevicius) #5

No it still works, yet your CPU most likely doesn’t have float support in the CPU:

And we don’t compile with soft float support.


(Jakob Borg) #6

Yeah, that could be it. Builds are ARM5 now at least.


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.