anyway to pull/force pull from peers?

so somehow my local copy of a synced directory got deleted. I can’t seem to find out what happened locally, so I deleted removed the folder in the gui and set another peer where the change hadn’t propogated yet to send only, and tried to re add it in the same spot. I keep getting the error message:

2022-05-02 18:27:20: Error on folder "obsidian_notes" (edysz-zrghd): folder marker missing (this indicates potential data loss, search docs/forum to get information about how to proceed)

I’m wondering if there is a way to do something like force pull, a way to say “just pull whatever from my peers(or a specific peer) and if there are conflicts, opt for overwriting the local files”

currently the only thing that has worked is to add the folder in a new place when syncing, and removing the folder from the gui, deleting the local contents and then readding it doesn’t seem to resolve the issue.

I’ve seen a few similar cases on the forum, and I think I’ve also experienced a similar situation myself while testing, where Syncthing would complain after removing and re-adding a folder in the same location. I’m inclined to believe that there may be some kind of a bug in here.

Normally you should be able to re-add the folder in the same path without any problems. Out of curiosity, what happens if you restart Syncthing first and only then try to re-add the folder?

1 Like

just tried, removed the folder, backed up and deleted the contents, and restarted on both ends. After adding back in the same spot, syncing was back to working

if this is a bug, is there any relevant logs I could post if my device wasn’t in audit mode? p.s. really can’t afford to try to reproduce/collect new relevant logs because I’m under a time crunch for the next 3-4 days (Finals)