Annoying issue with paused folder [solved]

Hi there. I’m unfortunately encountering some annoying behavior regarding a folder that I have paused. It’s been paused for quite some time (waiting upon the money to expand the old HDD array), and it’s generating a lot of “Folder “xxxxx-xxxxx” isn’t making progress. Pausing puller for 1m0s.” errors.

For reference, there are 3 nodes involved:

  1. “host” node – the main PC
  2. “local” node – a local backup PC, on the same LAN as “host”
  3. “remote” node – a backup PC offsite

The “host” node is often shut down, and frankly the LAN that “host” and “local” are on is crappy (powerline ethernet is not a win). As a result, the link between them is extremely slow (hence the fact that “local” hasn’t finished syncing from "host).

As a result, most of the folders synced by “host” actually sync to “remote” and “remote” then syncs them to “local”. All of this is fine (and not Syncthing’s fault) for the majority of folders. However, one folder is (manually) paused on “remote” due to lack of disk space.

Even when “host” is offline, “local” is still attempting to sync with “remote” – however, as “remote” is paused, it can’t… hence the constant “Folder “xxxxx-xxxxx” isn’t making progress. Pausing puller for 1m0s.” errors.

It seems that Syncthing is not communicating to “host” and “local” that “remote” is paused – can anyone confirm that this is the case, and if so, is there a workaround? If not, I’ll open a bug report so that it can get fixed.

One workaround would be to unshare the folder so that it doesn’t think it can sync it from the device where it’s permanently paused.

Yes, that would solve the issue, but it seems like a bit of a kludge, and additionally, I’m not sure how syncthing would handle files that are partially downloaded – would removing it and then re-adding it allow syncthing to resume them?

I’m not saying remove the folder, just uncheck the checkbox for the device it can never sync with. This doesn’t affect temp files or anything.

Thank you: brilliant, simple, solved.

Sorry, I misunderstood your OP.

*caveat for others: make sure to uncheck on all devices, the “share with” settings aren’t propagated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.