Android "won't accept sharing" even though both ends "Send and receive"; and change Android default

I’m bewildered setting up in Android 14 on a Pixedl 6A. I’d appreciate simple newcomer instructions please. Syncthing on Android tells me the default folder is


but this is greyed out. In the context menu it is set to share with my laptop, and folder type is send and receive, and watch for changes.

On the laptop’s default folder is also set to Send and REceive.

On the phone’s Files app under Internal Storage there is a folder called DCIM, which I assume is the same thing. But there’s nothing in here referencing file syncing. And the laptop tell me “The remote device has not accepted sharing” from the laptop’s default folder. And on both ends these folders are set to both send and receive.

I’m completely lost and I’ve no idea what to do. Even if I did know, I do NOT want the shared files mixed in the camera folder on Android, so how do I change that please?

Many thanks!

That’s odd. Best guess is that when the folder was configured in Syncthing, it was going to be named “Camera”, but it was inadvertently added to the folder path field instead.

The correct default path for camera images on Android is /storage/emulated/0/DCIM.

Once a folder has been added in Syncthing, changing the target folder requires accessing the advanced folder settings.

It’s faster and easier to just remove the folder from Synthing and re-add it. But for …

  1. Tap the hamburger menu (3 horizontal bars) in the upper-left corner in the app.
  2. Tap “Web GUI”.
  3. Tap the cog wheel icon in the upper-right corner.
  4. Tap “Advanced”.
  5. Tap “Folders”.
  6. Tap “DCIM” (most likely folder name, but it could be different).
  7. Scroll down to the “Path” setting and change the target folder to /storage/emulated/0/DCIM.

Please correct me if I’m wrong, but it sounds like you configured the folder separately on your phone and your laptop.

In order for two or more devices to sync a shared folder, the folder ID must be identical (see An Intro to the GUI for more details).

In addition, both your phone and laptop must have already accepted each other as authorized remote devices.

I recommend starting with a clean slate by removing the Syncthing folder from both the phone and laptop. Then confirm that both devices can “see” each other before adding any sync folders.

"Syncthing Made EASY"
Channel: Tech Craft
Date: Sep 18, 2022
Time: 00:28:29

If you need more help, screenshots of Syncthing’s panels from both the phone and laptop with details visible for each device and folder would be very helpful.

@gadget Thank you, this worked and the files appeared by magic. I must say that for me Web GUI isn’t the obvious place to look to set up folders, but it works and all is well. Many thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.