Android Backup Conflicts

I use SyncThing to backup my Android phone. The setup is:

  • SyncThing folder on Android points at the root of the device storage, & is “Send Only.” I only run it manually when I actually want to run a backup
  • SyncThing on 1 PC & 1 NAS each have a dedicated “PhoneBackup” folder. Both are set with “Ignore Permissions”.

The idea is that when I want to backup the phone, I open SyncThing, & the phone uploads to whichever device is nearest/fastest - i.e. if I’m on the same wifi as the laptop, it’ll sync locally to the laptop, but if I’m out & about, it will upload to the always-on NAS. Since the Nas & PC folders are Send & Receive, they can sync amongst each other once available .

This works, except that I constantly get conflicts & need to “Override Changes” from the phone, over & over, until the conflicts are gone.

  1. Since the files are never touched/modified anywhere but on the phone, which is Send Only, why are there constantly conflicts?
  2. How can I achieve the intended behavior? Phone can upload to either device, other devices sync amongst each other (but not to the phone) until both are up to date, without constantly having to “override changes” from the phone?

I think there should be no conflicts in this situation under normal circumstances. Are the Syncthing installations on all devices up-to-date? Also, have you tried checking the conflicted files whether they are actually identical or not (e.g. by comparing checksums, mtime, etc.)?

No, they aren’t up to date on all devices. Previous versions yielded invalid conflicts? If so, I guess updating them all is my next step.

Haven’t checked for diffs either, good idea. If they still occur after updating all clients, will do that & report back. Thanks!

Android is suspect because of the known problem with moving timestamps in the OS. There was a fix some time ago, but it’s been a while already, so it probably shouldn’t affect you unless your Syncthing installation on Android is older and hasn’t been updated in a while. If that’s the case though, then I’d definitely suggest to upgrade.

Also, with such a mix of different OS, I’d make sure to tick “ignore permissions” everywhere.

Actually Android was the one that’s the most out of date, so hopefully that was the issue!

And yup, ignore permissions is checked on all :slight_smile:

For fear of highjacking my own thread, I’m trying to get everything back in sync but am having another very weird behavior. I’ll spare the backstory (I’ve basically just been ignoring constant errors/issues in this android backup folder due to the above, but now that I’ve updated everything, would like to get a “fresh start”).

What I have now: ALL devices are paused except two: NAS and laptop (aka no android in the mix). There’s a particular subfolder PhoneBackup/Pictures/Messenger. Messenger is empty, and Pictures is empty except for Messenger (no hidden “dot” files in either folder, on either device). I can’t delete the Pictures foldder. If I delete it on the NAS, it reappears. If I delete it on the PC, it reappears. Those are the two only devices in the mix. Why will it not let me delete the “Pictures” folder?

Edit: I’ve even tried setting PC to “Send Only” & NAS to “Receive Only.” NAS shows “Revert Local Changes.” No matter how many times I click it, that subfolder will not remove. If I delete the subfolder myself, SyncThing recreates it.

Is this Pictures folder a subfolder of a different Syncthing folder, or is it an independent Synching folder in itself? If it’s the latter, have you enabled https://docs.syncthing.net/users/config.html#config-option-device.autoacceptfolders by any chance?

It was just a subfolder.

I have no idea exactly how, but after ~2hrs of fiddling with turning various devices on/off, re-scanning, setting things to send/receive only, etc, I finally got this older to stop recreating itself. Strange.

Alright, so it looks like updating the Android app was a huge improvement: so far no new conflicts (fingers crossed!).

However, the Android app does still ask me to “Override Changes.” As none of the files in this folder are ever touched on any devices but Android (per above, they’re purely there for Android->PC backup), not really sure why it would require me to “Override Changes?”

These aren’t actual conflicts, just a few random files that are shown as “Out of Sync Items” if I view the web GUI on Android.

Can you post screenshots of the Web GUI showing the specific messages?

Hmm, at this point it would probably be the most beneficial to take one of those files from both sides and compare them for any actual differences.

Alright - I already overwrote these changes, but will do that & follow up the next time it occurs.

Thanks

Ok, I have it up - as far as I can tell, the filename it’s showing on the phone (under “Out of Sync Items”) doesn’t exist anywhere. It’s a previous filename I had from awhile ago, but was already deleted. Don’t see it on the phone itself, nor on any of the PCs. However, as the screenshot shows, it only has the filename - not full path and filename - so I’m not actually certain exactly where it thinks that file is.