Alternative way to use ST on Android

(kahun) #1

Hi

I would like to thank @Nutomic for his efforts to bring it to Android. However the Android builds never worked for me and I always ended up having issues with it.

So I came up with an alternate way ot running ST on Android which relies on Arm build and Root access.

Download

-Select android as the user in the UI. Beware, non-root users cant get net unless you add yourself to inet group. This user will let us connect to localhost.The default pass for ssh is “changeme” so do not forget to change it afterwards.

  • Select custom mount and add your sdcard. The paths can be tricky you might need to try it couple times. The mount will be presented in /mnt/sdcard or so. You will use this basic path to access your folders in arm ST and the web gui not the Android path.

-Once the Linux is installed, run the distro from the menu. It will enable SSH access.

Download Connectbot

-Extract it to somewhere like /opt

  • enter the directory and run ./syncthing whcih will give you access to the web gui and such
0 Likes

(Felix Ableitner) #2

A simpler way would be to install the app and then execute /data/data/com.nutomic.syncthingandroid/lib/libsyncthing.so (also needs root). Or copy your own syncthing binary to the device.

0 Likes

(kahun) #3

well that is the issue. Android builds gave me issues. The main issue was that Android Syncthing never dies even after closing the program and uses most of the cpu as a zombie process.

It might be related to me using Xposed frame work. I am not sure but that could the what was casusing major headaches with ST for ANdroid.

0 Likes

(Felix Ableitner) #4

Did you try the latest version? (0.5.28) That kills the syncthing binary, instead of using the shutdown API call.

If that doesn’t help, could you try and find steps to reproduce that problem?

0 Likes

#5

I ran the Android version for some time with kitkat (custom rom though) and xposed… worked fine for me… I switched to lollipop now mainly (without xposed until is is stable) but can switch back to kitkat/xposed (is my secondary rom) if you want me to test something.

edit: oh and i used v0.5.28 under kitkat/xposed

0 Likes