Allow anonymous usage reporting?

Setup a couple of weeks ago on a new pixel 2 xl but am now getting a popup asking me if I want to allow anonymous reporting everytime I open the app. The only way to remove it is to hit the back key but it returns after a few seconds, see screenshot. Obviously I’ve tried hitting yes and no but that just asks me to restart syncthing and it pops up again.

Seems like it’s worth a bug report on the android tracker.

is there a way of generating a report from the app? where is best to post it to?

Ping @nutomic

Do you know how this problem can be reproduced? Have you actually tried restarting the app? And can you check what value is shown in the web gui settings for “Anonymous Usage Reporting”?

Yes of course, it asks for a restart if you choose yes or no but then immediately pops back up again. Same thing when you go to the web gui, I got a popup asking the same thing. I clicked yes and checked as you asked. It has “version 3” selected

Sorry I don’t know what might cause this, unless you can post steps to reproduce this. Only other thing I can think of is restarting your device.

I’m experiencing this, too. I’ll try to look into it later. It just started yesterday. I’ve restarted the device and it didn’t help, though I haven’t tried clearing Syncthing local data yet. Will dig in tonight…

There was a bug that was fixed. Upgrade to latest version.

Hello everyone

I’m experiencing this, too for 2 weeks and it was caused by the automatic update of my android box which upgraded syncthing from 0.9.17 to 0.10.3. I regressed to 0.9.17 when i discovered that and all went well.

Ok,confirmed, the issue is resolved in version 0.10.4. Note to others: My Android had for some reason tripped on the Syncthing auto-update, so to fix this issue, I had to go into the play store and actually hit “update” on the Syncthing app. It then updated to 0.10.4 and resolve the issue.