All devices appear disconnected

Hello everyone,

I have some trouble using ST at the university, and I don’t really know how to perform tests. So, essentially I have three devices, 2 Linux and an Android, all three at the University. They don’t see each other, i.e. they appear “disconnected” on each other’s gui. So I was wondering:

  • If it is possible that University blocks ST when all three devices are within the Uni (for sure this is a stupid question),
  • Which tests I should do to make a diagnostic.

Some info:

  • I can ping both pcs.
  • I am running version 12 on all devices.
  • nmap says that port 22000 is open on the pcs.
  • Global discovery is enabled, as well as UPnP. More generally, I left all options by default.

Thank you very much for any help, and thank you for bringing ST to life :).

UPnP probably won’t work, as the routers of the university won’t accept port mappings via UPnP. As your devices are not accessible from the internet and if you don’t use other devices outside the university, global discovery makes no difference. UPnP and global discovery is in generally unimportant when all devices are in the same network.

Is local discovery enabled? This is necessary for the devices to find each other inside the same network. If it is enabled, than the needed broadcast/multicast is probably disabled in the university network.

If you have fixed IPs, or can use computernames instead of IPs when trying to ping, you can edit the external devices in sycnthing and change dynamic to e.g. tcp://ip-address:22000, dynamic or tcp://computer-b:22000, dynamic (where ip-address is the ip and “computer-b” is the computername of one of the other syncthing nodes.

They should still be able to relay to each other, surely? Unless the Uni’s blocking something necessary there…

Do you need a proxy to access the internet at your Uni?

@wweich: Yes local discovery is enabled, and I tried tcp://ip-address:22000, dynamic with a local ip address but no chance…

@canton7: Yes, I guess the university is blocking something necessary, but I don’t know what. And I don’t need a proxy to access the internet.

I guess I will try to switch back to bitsync for the time being (I need to do some heavy sync these days), but I am very much interested in syncthing so I will come back :). If you have any other idea, or hope that it might work with a future release of ST, do not hesitate.

Thanks for the help.

Just to be sure: Where did you enter this? In what field?

In the field “Global discovery servers”. Is that right?

It is when you edit a device you want to connect to under Addresses (description Enter comma separated ("tcp://ip:port", "tcp://host:port") addresses or "dynamic" to perform automatic discovery of the address. under it)

You mean “Sync Protocol Listen addresses”?

not in that settings screen, the screen where you add and edit remote devices: click on device in the device list on the right side -> edit -> Addresses

On the main screen of syncthing you need to expand one of the devices on the right and click edit. There you need to replace the dynamic in the field “Adresses” with tcp://ip-address:22000, dynamic.

If you have device A and B, you need to open the webui of device A, there you need to expand and edit device B and enter the ip-address of device B in as described above.

Alex was faster :slight_smile: .

Sorry, I am being a bit stupid. And it indeed, it worked, thanks very much guys :). Maybe one could put this trick in the FAQ?

So, one additional questions. I did not try yet, but I guess I will have some trouble connecting from outside the uni. Given that I do not have public addresses on the computers within the uni, is there anything I could try?

Thanks again!

Which devices are outside the Uni? as you still have dynamic in the adress field, the default behaviour (global announce) still works (if enabled) and the devices outside the Uni need to be reachable (port forward or UPnP). But mobile devices are not reachable most of the times.

That would be one pc inside the uni, one outside. I will try tonight, see how it goes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.