"Add Folder" dialog not enabling the "Save" button


I have been running syncthing for 8 months. I’m not an expert but I’m pretty OK and more or less know my way around. I typically use the WebUI on Windows10.

My remote colleague wants to share a folder with me. I received the request to add his machine, and I accepted and restarted.

I then received a request that he was trying to share a folder with me. When I accept the request I am taken to the “Add Folder” dialog. I fill out the form but the “Save” button is not enabled.

The same result when I try to manually add the folder.

I worked around by directly editing the config.xml to add the folder and that worked fine.

Any ideas on what I’m doing wrong or what I need to check please?

Can you post a screenshot?

Hi Audrius,

Well, typical. It’s all working just fine now it seems. I can add folders, I can accept sharing requests, etc, and everything is fine. I’ll keep an eye on it but I expect it will continue working OK. Thank you for responding.


Are you using SyncTrayzor, and specifically the ‘Browse’ button next to the folder path input box, by any chance.

Are you sure that the “Folder ID” field is well completed when you add the folder ? If not, the save button not works.

Hi, I had same issue then discovered the folder path requires a backslash even after using browse. e.g. C:\example folder path will not allow save whereas C:\example folder path\ does allow.

Hope this helps as it took me ages to discover it.


This isn’t the issue: both are allowed by the validation.

Hi, yes, as it turns out, I was using SyncTrayzor. But as I’ve said, it just started working again for no apparent reason. If it happens again, I’ll make sure I grab screenshots.

Thanks again


There’s a bug: using the ‘Browse’ button doesn’t trigger re-validation. So if the form input was invalid (e.g. no folder path) before you used the ‘Browse’ button, it won’t become valid after using the ‘Browse’ button.

It will be fixed in the next release. Until then, change anything in the form (add a character then remove it, etc) to trigger revalidation.

… That’s why I asked ages ago if you were using SyncTrayzor :wink:

Oh, right, it’s just that was how it worked for me. Just tried it now and without the backslash it wouldn’t let me save, but on adding it it did allow. I wonder if it’s SyncTrayzor then, as I am using that.



Yep that browse button is a SyncTrayzor addition.

Adding a backslash works because of what I said before: make any change, and validation kicks in ans enables the save button. Remove the backslash and it will still let you save.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.