Active connections but unable to visit local GUI on 8384

I recently fiddled with my Syncthing install on one of my widows peer machines with the vanilla Syncthing.exe setup. When I start it up, it is successful and I’m able to see file syncs successfully complete/delete/modify files however I’m unable to get to the GUI on my localhost by navigating to

Error text is: dial tcp connect: connection refused

I didn’t make any changes to my firewall or connection settings (at least not knowingly) and in any case, it’s a local connection so it doesn’t make sense that it would be network related.

The syncthing.log in %localappdata%/Syncthing shows the following line: 2023/04/06 17:56:06 INFO: GUI and API listening on …meaning I think it should be attempting to present the GUI/API on that port.

I’m otherwise on the internet and everything on the computer, but I’m just not sure what the heck is going on that could be preventing me from accessing the GUI.

When I attempt to navigate to the GUI, the syncthing.log does not change at all, so I think it’s my computer not letting me talk to the GUI.

Things that changed recently:

  • installed new version of syncthing v1.23.4 “Fermium Flea” (go1.19.6 windows-amd64) 2023-04-05 13:25:55 UTC
  • moved my syncthing.exe and surrounding folder, temporarily, to a new location
  • when I moved my install, I accidentally had the old syncthing.exe running so the log showed a few lines of “failure to start” because an instance of syncthing was running already, which is fair

I’m at a loss and am sure it’s a simple thing I’m overlooking…anyone have a hint for me?

Step one is to look at the list of open network ports to see if Syncthing is really listening to that port. See .

1 Like

Thanks for responding!

From the looks of it, the PID listening on 8384 is indeed syncthing.exe, so syncthing is listening there, I think.

I also tried adding these ports specifically to the outbound and inbound on the windows defender firewall temporarily to see if that might be the issue.

Okay, this is dumb, but I’ll share in case it helps someone else out.

I found the issue and it was that my browser had a VPN extension active on it. When I turned off my VPN extension, it then pulled up the available GUI right away which was listening and available the whole time.

Funnily I thought this might be the case but I tried my other browser and I guess that one also had the same extention to auto-start so it was doing the exact same thing.

Anyways…my bad and lesson learned. Thanks all


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.