Acer Spin 5 does not wake up from sleep mode


For the past couple of months or so, I’ve been experiencing a problems with my waking up my acer Spin 5 from sleep mode. I’ve noticed that when I let it go to sleep mode (or hibernate), sometimes it would not manage to boot up again.

I’ve managed to track the issue when syncthing is up and running.

Syncthing version: 1.12 operating system: Windows 10 home (fully patched)

What happens

When I start syncthing and I leave it running, if the computer goes into sleep mode/hibernation then it is not possible to wake it up. What happens is that the keyboard lights up (as it should), but there is no other response from the system.

The only way to get the computer operational again, is to press the power button for a few minutes (hard reset) and then restart it.

That behavior only happens when I have syncthing running. I’ve tried that (see below).

More details on how I came to the conclusion

Initially, I thought it was some sort of corruption through the updates of windows. I’ve had the Acer Sping 5 for 3 years, and it worked with syncthing without a problem all this time. I need to note that because the Spin5 is my carry around laptop, to save some time during boot, i’ve had syncthing disabled at boot, and occasionally I start it up. However, I never had a problem before (I use syncthing to sync between at least 5 pc’s and various operating systems without a problem). That is the reason, why I didn’t suspect syncthing earlier.

At some point about a couple of weeks ago, I decided to refresh the Windows 10 installation to see if that fixed things. I did the full refresh, and I slowly started to add things. Then last week the same problem happened (I would try to boot windows from sleep mode, but nothing happened apart from the keyboard lighting up). For the past week, I’ve avoided using syncthing, and the behaviour was as expected. Then yesterday, I rebooted the computer, started syncthing, and then let it go to sleep mode, and I couldn’t start it again (as I’ve mentioned above I have to use the power button to power down the pc and then restart it).


The only workaround I’ve found so far is to shutdown syncthing whenever I don’t use the computer.


  • Does anyone have a similar problem?

  • Can anyone help, with verifying/understanding/pinpointing what the problem is from the logs on Windows/syncthing, so that I can post a proper bug issue.

I don’t really think this is our bug, as the operating system should not behave that way.

I suggest you can try disabling filesystem watcher to see if that helps it. But other than that, best I can suggest is to reinstall windows and see of that helps.

I also thought that there might be a problem with windows, so I did reinstall windows (I used the full refresh option which essentially did a complete installation of windows). However, the problem persisted.

I will try disabling the filesystem watcher and see if that helps.

I would not say that the two are the same… especially if this is a laptop with pre-installed software from the manufacturer. If that is the case, then I would suggest a full reinstallation using the official ISO from the Microsoft’s website.

It is a laptop with preinstalled software, so I might have a go at it. One thing I am worried about is how am I going to transfer the valid license when I reinstall.

I mean, over the last 3 years the license on the sticker has faded away, and I can’t even see it. So, refreshing was a better option because I was certain I would not be asked for a license number/product key. So I need to find a way to extract the product key.

There are plenty of ways to extract the key, but these two are quite simple (and require no 3rd party tools).

I have no experience with Acer, but judging by the amount of preinstalled garbage on laptops made by companies like Samsung, LG or Lenovo, I would not be surprised if some of it messes with sleep and hibernation.

Thanks for the link.

I agree that the bloatware can mess up your installation, but for the past 3 years I did not have any problem. Its hard to see why now it should matter. But in any case, I will have a go and try what you suggested.

Thanks again.

Well, of course, there is no guarantee that the bloatware is the actual culprit :upside_down_face:. Troubleshooting Windows can be difficult though.

Still, maybe the Event Viewer shows something useful? Also, some software like antivirus or drivers can lead to such issues too.

Syncthing itself should not cause problems with sleep or hibernation. I personally hibernate one of my devices with Syncthing running on a daily basis and have not experienced any issues with waking it up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.