Accidently changed IP

Hello! I was trying to make my android webui accessible on my network and I accidently saved is as and now I can’t get back into the local webui or revert this setting. The server attempts to start but gets stuck because of the incorrect IP. Android data folder only has the log and not the config.xml. any way to fix this without nuking my saved settings and synced folders?

Have you saved this broken address in the app settings or the Web GUI? If the latter, just completely closing and restarting the app (or just rebooting the OS) should restore the old address. On the other hand, if you’ve done this only in the app settings, then you should be able to just change it back there.

Just for the record, if you want to make the GUI accessible outside of the device, you need to set the GUI address to in the app settings (not the Web GUI!).

I did it in the web gui and I have restarted the device a few times but the settings seem to have stuck. Log shows that it’s trying to use that IP. I can access the app settings by disabling WiFi but I can’t find any setting that it will allow me to change while the server is not running, they are greyed out. If I try to enable the server it won’t allow me to select the options (android hamburger menu) because it’s trying to start the server.

Hmm, this sounds very strange as normally the app is supposed to override the GUI address on start precisely to prevent something like this from happening :confused:.

Are you able to use the built-in backup function to export and import the configuration? If yes, then after exporting it, you should be able to modify the address inside config.xml, and then import the modified files back into Syncthing.

Both Syncthing Options and Backup are greyed out when the server hasn’t been started from what I see.

This is the error in the log: WARNING: Starting API/GUI: listen tcp bind: cannot assign requested address

Is the phone rooted? If yes, then you could modify the config file directly in the app data. Otherwise, it seems that reinstalling the app from scratch may be the only way to make things work again…

No it wasn’t rooted and I had to reinstall the app. Not sure why syncthing settings are inaccessible when it isn’t running with WiFi off. Seems like that’s the perfect time to change settings. :slight_smile:

I do appreciate the help though!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.