Access to Android GUI from PC browser

I have Android v1.27.1 64-bit ARM running on my Samsung phone. When connected to my home network via wi-fi, it synchronizes as desired with folders that reside on one of my PCs that is running v1.27.1, Linux (32-bit ARM). I’d like to use the browser on the PC to monitor the state of the phone’s files. While I can use a browser on any of my PC’s to monitor the Syncthing GUI of any other PC in the house, I haven’t been able to figure out how to get the Android web GUI to connect with my PC’s browser. The Web GUI tab of the Syncthing app on my phone displays the GUI as it should. But when I try to browse to from my PC browser, it reports ERR_CONNECTION_REFUSED. Does the Android app support http connections other than via

There is a setting in the app to change the port (don’t change it in the Web GUI!). You need to set it to for remote access. Please also be aware that on Android, the username is hard-coded to “syncthing” and the password to the API key, and you cannot change them for now.

Thanks @tomasz86. Worked like a charm! I might have figured out the change to the listen address (App menu > Settings > Syncthing Options > GUI Listen Addresses > and maybe even the GUI account name (App menu > Web GUI > Settings > GUI Tab > GUI Authentication User). But I doubt if I’d have guessed to use the API Key as the user account password.

Do you know if the Android client supports the REST APIs? I have a Perl script that I use to periodically poll my various Syncthing clients to check for out-of-sync conditions and send me an email if anything is out of whack. I’d love to use it to check the Android too. If the APIs are supported, I’ll start another topic to make any questions more easily visible to anyone who might be interested.

Never mind my question about Android support for the REST APIs. I ran my script from one of my PCs using the phone’s IP and password and it reported back just fine.

Just for the record, if you do change them in the Web GUI, they will reset back to “syncthing” and the API key after restart. This is a known issue and limitation.


I can’t remember the name of the program but one of the other support professionals in the past mentioned to me a program that runs at the command prompt and shows an output of Statistics from all of the servers that it sees. Can you post the name of that app and where to download it from?

This user might find that app useful as well as it will fit into his scripting skills especially when wanting to send an email from the command prompt based upon output from the terminal.

@wank, a program like the one you mention sounds like it would be very helpful.

1 Like

Update: Yesterday I reported that my script successfully obtains status from my Android phone when the script is run from a Windows 11 PC. Further testing revealed that the same script run from a Linux host running Debian 11 fails to connect to the phone. Research showed that the Android client was passing a self-signed certificate to the script for authentication of the connection, and the Linux host rejected the connection (Error 500: certificate verify failed).

I was able to get the Linux host to allow the connection only by disabling SSL from within the script by setting SSL_verify_mode => 0. Since all of this is happening behind my firewall, I’m ok with disabling SSL in this case. But I’d prefer to keep things ‘secure’ if possible.

My Windows and Linux Syncthing clients are configured to use my own custom SSL certificate and key (https-cert.pem and https-key.pem as described in Syncthing Configuration) but I don’t see a way to configure the Android client with my own cert/key.

If you use the built-in backup in the app, it will export the following files:


I think you should be able to just replace the two HTTPS-related ones with your own versions while leaving the others untouched, and then use the same backup function to restore the existing backup, which will effectively import those files into Syncthing.

@tomasz86. As you suggested, I used App menu > Settings > backup > export, replaced the two https files, then imported the modified backup. Then the script ran without issues on both Windows and Linux. However…

Rather than replace the existing https files, I renamed the originals (https-cert.pem.original), but left them in place. Then I copied my two https files in, named appropriately. As noted, the script ran as desired, and synchronization works as desired. But the Backup and Syncthing options choices on the app’s Settings menu were grayed out. When I restarted the Syncthing app on the phone, it displays a spinning circle (loading…) and never seems to initialize properly. Killing all the apps on the phoine and restarting the phone completely doesn’t help. The Syncthing app doesn’t initialize on the phone.

I suspect I’ll have to re-establish the folder connection with the other Syncthing serve on my PC?

Oops! Further research shows that I screwed up (not for the 1st or last time ;-). Anyway, I just realized that the certificates I created for myself do not include the IP/SAN for the phone in the list of authorized end users. So, I’ll have to spend some time re-generating and deploying an updated certificate for use on the phone.

Meanwhile, FWIW, synchronization continues to work as desired. I can use the Web GUI from my PC to connect to the phone’s server and monitor the phone (although I have to acknowledge the NET::ERR_CERT_COMMON_NAME_INVALID warning in my browser and accept an insecure connection.) And the script successfully polls the phone for status as desired.


Earlier today I sent a direct message to the specific technician that assisted me several months ago in implementing this utility along with a command line SMTP send application.

It displays in a nice neat list of everything that’s going on with every server. I will give you the link to the download when I get it, assuming that I do.

I was expecting to find it on the downloads page only it’s not there. I hope it wasn’t taken away.



Here you go! I just received the download link:

Let me know if you have any questions running it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.