A phone, a laptop, and a desktop

Hi –

SyncThing is working wonderfully between my phone and my laptop, and between my laptop and my desktop, but not always between my desktop and my phone, and I can’t figure out why. I frequently see this error…

No connection could be made because the target machine actively refused it. (19:40:43)

…but sometimes there’s a connection with a halfway decent transfer rate, and sometimes nothing. Any help anyone could provide would be greatly appreciated!

Thanks, Brian

Could you provide more information, e.g. the operating systems involved, versions of Syncthing used, etc.? Some screenshots of the Syncthing UI and logfiles from all devices would also help.

And here’s the log from the phone.

SyncThing - phone.txt (9.7 KB)

Here’s the GUI settings for the desktop and the laptop, respectively.

I have briefly checked the logs. Please mind that I am not expert, and there are people way more knowledgeable on the forum than me, but I can see at least two problems.

Firstly, on the phone you have this:

2021-03-02 00:52:05 Error on folder "Pictures" (kd1o7-tx7jv): insufficient space on disk for database (/data/user/0/com.nutomic.syncthingandroid/files/index-v0.14.0.db): 0.8 % < 1 %

which is a major issue, as Syncthing cannot operate normally without enough space for its database.

Secondly, both on the desktop and the laptop, the logs are flooded with these errors:

[T4HVY] 19:03:34 INFO: Could not connect to relay relay:// dial tcp connectex: An attempt was made to access a socket in a way forbidden by its access permissions.

I am not exactly sure whether this is a problem with your connection or the relay itself. Someone else will have to comment on that.

1 Like

And finally, here are some screenshots from the phone:

The space problem is no longer an issue. Some very large files were being transferred onto my phone’s internal memory and have been moved over to the microSD card.

I saw that “Enable Relay” was checked for the laptop, so I briefly enabled it for the phone and the desktop to see if that would help, but saw no improvement, so I unchecked it for all three. If my memory is correct, I read that unchecking “Enable Relays” under “Connections” would result in a faster transfer over a local network.

I personally would not play around with the settings unless you have specific reasons for doing so. There may be speed difference between connecting directly and through a relay, but without the relays, you may not be able to connect at all, especially if the phone is used in different locations, e.g. outside and through a mobile network.

Since you have connectivity issues, I would suggest to bring everything back to the defaults, which in this case are

Also, on the phone, you can swipe from the left and click a button to access the same Web UI as the you have on the other devices, so that you can make sure that everything is set the same way.

Lastly, is there any reason for using an older version on the phone? If not, then probably upgrading to the newest release will be a good idea, just to eliminate potential bugs, etc.

Good call. I had no idea I was using an outdated version on my phone. I’ll upgrade immediately and report back.

There seems to be a reliable connection between the phone and the desktop now. I’ll report back if anything changes. Now if only I had a stable internet connection in Windows 10…

Thanks, @tomasz86! (tried posting this yesterday, but apparently something prevented that from happening)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.