A message sent on a datagram socket was larger than the internal message buffer


I’ve been using Syncthing for a couple of weeks now with no issues. I’ve sync’d 2.5TB or so. However, starting the last day or two I’ve been getting the following message constantly. Any suggestions? [4VGKL] 15:02:58 INFO: Connection to XXXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX at [::]:22000- closed: reading length: INTERNAL_ERROR: write udp [::]:22000-> wsasendto: A message sent on a datagram socket was larger than the internal message buffer or some other network limit, or the buffer used to receive a datagram into was smaller than the datagram itself.

Any help would be appreciated.

Check network MTU. I think we assume that MTU is 1500 because it’s not trivial to do MTU discovery on windows.

As I mentioned, it has been working up until the last day. I’ve downgraded to version 1.18.1 after reading this, syncthing v1.18.2 has QUIC datagram size issues on Windows, and the error has gone away.

Someone in that linked thread was able to reproduce and filed mtu_discoverer: INTERNAL_ERROR on Windows · Issue #3273 · lucas-clemente/quic-go · GitHub, which lead to disable Path MTU Discovery on Windows by marten-seemann · Pull Request #3276 · lucas-clemente/quic-go · GitHub, which is part of quic-go v0.24.0. We are on v0.23.0. Good reason to upgrade.


Upgrade what sorry? Quic-go? I have no idea what that is sorry. Isn’t it part of Syncthing? I tried disabling Path MTU discovery on Windows at both ends (source and target) but that didn’t work. Downgrading Syncthing fixed it.

I was already running the latest version of Syncthing but ran into this problem.

There is already a PR: build: Bump quic-go to 0.24.0 by imsodin · Pull Request #8086 · syncthing/syncthing · GitHub

1 Like

OK, great. Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.