a lot of Out of Sync Items

Hey syncthing-community,

I just started using syncthing a few days ago and installed v1.27.3 as a docker image on an unraid server and as apckage on an old Synology NAS. The NAS is marked as Untrusted so the files are saved encrypted. I configured 3 Folders and 2 of them sync without any problems. The biggest folder has more then 100.000 photos and videos, ~521 GiB. This folder stopped syncing after a time and Remote Device shows 64.525, ~356 GiB “Out of Sync Items”. I already checked file permissions but don’t find any problems (0777) In The logs I find a read: connection reset by peer but I can add an additional folder and it syncs fine. Restarting server and NAS did not help.

Log shows:

(...)
2024-02-21 21:16:05 Single thread SHA256 performance is 479 MB/s using minio/sha256-simd (478 MB/s using crypto/sha256).
2024-02-21 21:16:05 Hashing performance is 430.66 MB/s
2024-02-21 21:16:05 Overall send rate is unlimited, receive rate is unlimited
(...)
2024-02-21 21:16:05 QUIC listener ([::]:22000) starting
2024-02-21 21:16:05 ...
2024-02-21 21:16:05 TCP listener ([::]:22000) starting
2024-02-21 21:16:05 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting
2024-02-21 21:16:05 GUI and API listening on [::]:8384
2024-02-21 21:16:05 Access the GUI via the following URL: http://127.0.0.1:8384/
(...)
2024-02-21 21:16:07 Ready to synchronize "mnt-user-kai" (osbbe-4zkrk) (sendonly)
2024-02-21 21:16:07 Ready to synchronize "mnt-user-photo" (qlauz-cb3ua) (sendonly)
2024-02-21 21:16:07 Ready to synchronize "upload" (re3xc-uo7ew) (sendreceive)
2024-02-21 21:16:07 Completed initial scan of sendreceive folder "upload" (re3xc-uo7ew)
2024-02-21 21:16:25 quic://0.0.0.0:22000 detected NAT type: Port restricted NAT
2024-02-21 21:16:25 quic://0.0.0.0:22000 resolved external address quic://85.85.85.85:22000 (via stun.syncthing.net:3478)
2024-02-21 21:16:29 Detected 1 NAT service
2024-02-21 21:16:41 Joined relay relay://195.195.195.195:443
2024-02-21 21:17:34 Completed initial scan of sendonly folder "mnt-user-photo" (qlauz-cb3ua)
2024-02-21 21:18:49 Completed initial scan of sendonly folder "mnt-user-kai" (osbbe-4zkrk)
2024-02-21 21:21:38 Listen (BEP/tcp): TLS handshake: read tcp 172.17.0.2:22000->192.168.199.11:59453: i/o timeout
2024-02-21 21:23:02 Listen (BEP/tcp): TLS handshake: read tcp 172.17.0.2:22000->192.168.199.11:53311: i/o timeout
2024-02-21 21:23:20 Listen (BEP/tcp): TLS handshake: read tcp 172.17.0.2:22000->192.168.199.11:53314: i/o timeout
2024-02-21 21:23:33 Established secure connection to OI4Q4KN at 172.17.0.2:22000-192.168.199.11:22000/tcp-client/TLS1.3-TLS_CHACHA20_POLY1305_SHA256/WAN-P30-(...)
2024-02-21 21:23:33 Device OI4Q4KN client is "syncthing v1.27.3" named "nas" at 172.17.0.2:22000-192.168.199.11:22000/tcp-client/TLS1.3-TLS_CHACHA20_POLY1305_SHA256/WAN-P30-(...)
2024-02-21 21:23:33 Failed to exchange Hello messages with (...) at 172.17.0.2:22000-192.168.199.11:53317/tcp-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256/WAN-P30-(...): read tcp 172.17.0.2:22000->192.168.199.11:53317: read: connection reset by peer
2024-02-21 21:46:06 Sent usage report (version 3)
2024-02-21 22:40:23 Paused folder "mnt-user-photo" (qlauz-cb3ua) (sendonly)
2024-02-21 22:42:18 Ready to synchronize "mnt-user-photo" (qlauz-cb3ua) (sendonly)
2024-02-21 22:42:18 Unpaused folder "mnt-user-photo" (qlauz-cb3ua) (sendonly)
2024-02-21 22:43:08 Completed initial scan of sendonly folder "mnt-user-photo" (qlauz-cb3ua)

Any ideas?

I’ve seen a couple of similar reports lately, where the initial sync didn’t complete and got stuck with “Out of Sync”. Best advice in those other cases was to remove the folder on both sides (from Syncthing configuration, NOT the actual files!) and share them again.

Have you ckecked the list of items it sees out of sync? Might be a clue in the file names, if something contains forbidden characters on either end.

hi

take also care of path+filename length, eg if receiving folder is deeper in folder tree.

I also have out of sync items after first adding a new folder, but no files are shown in the overview. I tried to delete and add the folder again in syncthing with the same result. I tried to move the files out of the folder and back in (on the smartphone). Same result. I looked for hidden, empty or files without file extension and could’t find any.

Any ideas?

Thx 4 F1.

nosync_1

My solution was exactly what acolomb wrote in comment #2: removing the folders on both sides and adding completely new. So this wasn’t a problem with characters or permission.

I think I had similar issue here :frowning:

https://forum.syncthing.net/t/missing-half-of-the-photo-files-but-the-status-shows-100-completed-on-src-and-target/

And I’m starting to wonder if the Syncting is still a reliable solution.