16:32:09 FATAL: Opening lock port: listen tcp bind: cannot assign requested address


I installed on one of my laptops and this is the message I am getting. I am running it via terminal on Debian 64.

I get it, the port is locked by why?

When I ran it the first time, it ran but I could not connect to It said the web server is running but the page was not loading so I killed the process and restarted, now that is all I get. And no syncthing is running anywhere.


That error looks like it can’t open a listening port on any port (:0 is to ask the system to assign a free one). In other words, that’s really weird. Don’t you have a address on your system?


I have no idea why it is throwing that error now ;( The port is not block, it looks like it is prematurely exiting for some reason to me.

mmap(0xc208100000, 1048576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xc208100000 mmap(0xc207fe0000, 65536, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xc207fe0000 futex(0xcdf0f8, FUTEX_WAKE, 1) = 1 futex(0xc208017bf0, FUTEX_WAKE, 1) = 1 mmap(0xc208200000, 1048576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xc208200000 mmap(0xc207fd0000, 65536, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xc207fd0000 futex(0xcdf0f8, FUTEX_WAKE, 1) = 1 futex(0xcdf0f8, FUTEX_WAKE, 1) = 1 socket(PF_INET, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, IPPROTO_IP) = 3 setsockopt(3, SOL_SOCKET, SO_BROADCAST, [1], 4) = 0 setsockopt(3, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0 bind(3, {sa_family=AF_INET, sin_port=htons(0), sin_addr=inet_addr(“”)}, 16) = -1 EADDRNOTAVAIL (Cannot assign requested address) close(3) = 0 open("/etc/localtime", O_RDONLY) = 3 read(3, “TZif2\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\6\0\0\0\6\0\0\0\0”…, 4096) = 3559 read(3, “”, 4096) = 0 close(3) = 0 write(1, “08:27:48 FATAL: Opening lock por”…, 9708:27:48 FATAL: Opening lock port: listen tcp bind: cannot assign requested address ) = 97 exit_group(1) = ? +++ exited with 1 +++

Really bizarre. I ifconfig lo down and ifconfig lo up. Now it works ;(

This is the operating system refusing to let syncthing open a port on the lo interface, so there’s something weird there.

Edit; Ah, I see you solved it.

2 posts were split to a new topic: “FATAL: get free port (GUI): listen tcp errno -9” on startup